aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2023-09-07 12:37:50 -0400
committerLudovic Courtès <ludo@gnu.org>2023-09-14 23:36:35 +0200
commit9620b9d29858c05c774c15c3011bd610ce7ab671 (patch)
treeeef89f7b8d4966e3616156ef98a133c16b113223 /gnu/packages
parentc057507a0bac3ee5885a4ef055c9fea44683a1c3 (diff)
downloadguix-9620b9d29858c05c774c15c3011bd610ce7ab671.tar.gz
guix-9620b9d29858c05c774c15c3011bd610ce7ab671.zip
gnu: libftdi: Update package style.
* gnu/packages/libftdi.scm: Re-order #:use-module statements. (libftdi): Wrap long lines; reformat gently. [license]: Use "license:" prefix. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/libftdi.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/libftdi.scm b/gnu/packages/libftdi.scm
index e39e0b3d71..4cfa1d3424 100644
--- a/gnu/packages/libftdi.scm
+++ b/gnu/packages/libftdi.scm
@@ -18,12 +18,12 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages libftdi)
- #:use-module (guix licenses)
+ #:use-module (guix build-system cmake)
#:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (gnu packages)
- #:use-module (gnu packages libusb)
- #:use-module (guix build-system cmake))
+ #:use-module (gnu packages libusb))
(define-public libftdi
(package
@@ -32,18 +32,17 @@
(source (origin
(method url-fetch)
(uri (string-append
- "http://www.intra2net.com/en/developer/libftdi/download/libftdi1-"
- version ".tar.bz2"))
+ "http://www.intra2net.com/en/developer/libftdi/download/"
+ "libftdi1-" version ".tar.bz2"))
(sha256
(base32
"0x0vncf6i92slgrn0h7ghkskqbglbs534220qa84d0qg114zndpc"))))
(build-system cmake-build-system)
(propagated-inputs
- (list libusb)) ; required by libftdi1.pc
+ (list libusb)) ; required by libftdi1.pc
(home-page "https://www.intra2net.com/en/developer/libftdi/")
(synopsis "FTDI USB driver with bitbang mode")
(description
- "libFTDI is a library to talk to FTDI chips: FT232BM,
-FT245BM, FT2232C, FT2232D, FT245R and FT232H including the popular
-bitbangmode.")
- (license lgpl2.1)))
+ "libFTDI is a library to talk to FTDI chips: FT232BM, FT245BM, FT2232C,
+FT2232D, FT245R and FT232H including the popular bitbangmode.")
+ (license license:lgpl2.1)))
options, ghc-optparse-applicative, ghc-pandoc, ghc-pandoc-citeproc, ghc-pandoc-types, ghc-parallel, ghc-parsec-numbers, ghc-parser-combinators, ghc-parsers, ghc-path, ghc-path-io, ghc-paths, ghc-patience, ghc-pcre-light, ghc-persistent, ghc-persistent-sqlite, ghc-persistent-template, ghc-polyparse, ghc-pqueue, ghc-prelude-extras, ghc-pretty-hex, ghc-pretty-show, ghc-primitive, ghc-profunctors, ghc-psqueues, ghc-random, ghc-raw-strings-qq, ghc-rebase, ghc-reducers, ghc-refact, ghc-reflection, ghc-regex, ghc-regex-applicative, ghc-regex-base, ghc-regex-compat, ghc-regex-compat-tdfa, ghc-regex-pcre-builtin, ghc-regex-posix, ghc-regex-tdfa, ghc-regex-tdfa-text, ghc-rerebase, ghc-resolv, ghc-resource-pool, ghc-resourcet, ghc-rfc5051, ghc-rio, ghc-safe, ghc-safe-exceptions, ghc-safeio, ghc-safesemaphore, ghc-sandi, ghc-scientific, ghc-scientific-bootstrap, ghc-sdl, ghc-sdl-image, ghc-sdl-mixer, ghc-securemem, ghc-semigroupoids, ghc-semigroups, ghc-semigroups-bootstrap, ghc-setenv, ghc-setlocale, ghc-shakespeare, ghc-shelly, ghc-silently, ghc-simple-reflect, ghc-simple-sendfile, ghc-skylighting-core, ghc-skylighting, ghc-smallcheck, ghc-socks, ghc-split, ghc-statevar, ghc-statistics, ghc-stm-chans, ghc-stm-conduit, ghc-stmonadtrans, ghc-storable-complex, ghc-streaming-commons, ghc-strict, ghc-stringbuilder, ghc-string-qq, ghc-stringsearch, ghc-stylish-haskell, ghc-syb, ghc-system-fileio, ghc-system-filepath, ghc-tagged, ghc-tar, ghc-temporary, ghc-temporary-rc, ghc-terminal-size, ghc-texmath, ghc-text-binary, ghc-tf-random, ghc-th-abstraction, ghc-th-expand-syns, ghc-th-lift, ghc-th-lift-instances, ghc-th-orphans, ghc-th-reify-many, ghc-time-locale-compat, ghc-tldr, ghc-transformers-base, ghc-transformers-compat, ghc-tree-diff, ghc-trifecta, ghc-tuple-th, ghc-typed-process, ghc-unbounded-delays, ghc-unexceptionalio, ghc-union-find, ghc-uniplate, ghc-unix-compat, ghc-unix-time, ghc-unliftio, ghc-unliftio-core, ghc-unordered-containers, ghc-unordered-containers-bootstrap, ghc-uri-bytestring, ghc-utf8-string, ghc-utility-ht, ghc-uuid, ghc-uuid-types, ghc-validation, ghc-validity, ghc-vault, ghc-vector, ghc-vector-algorithms, ghc-vector-binary-instances, ghc-vector-builder, ghc-vector-th-unbox, ghc-void, ghc-wave, ghc-wcwidth, ghc-wcwidth-bootstrap, ghc-weigh, ghc-wl-pprint, ghc-wl-pprint-annotated, ghc-wl-pprint-text, ghc-word8, ghc-x11, ghc-x11-xft, ghc-xdg-basedir, ghc-xml, ghc-xml-conduit, ghc-xml-types, ghc-yaml, ghc-zip-archive, ghc-zlib): Move variables from here... * gnu/packages/haskell-xyz.scm: ...to here. * gnu/packages/agda.scm, gnu/packages/bioconductor.scm, gnu/packages/bioinformatics.scm, gnu/packages/cran.scm, gnu/packages/emacs-xyz.scm, gnu/packages/games.scm, gnu/packages/graphics.scm, gnu/packages/haskell-apps.scm, gnu/packages/haskell-check.scm, gnu/packages/idris.scm, gnu/packages/statistics.scm, gnu/packages/wm.scm: Update module references. Co-authored-by: Timothy Sample <samplet@ngyro.com> Robert Vollmert 2019-08-07gnu: Remove ghc-parsec, ghc-stm, ghc-text, ghc-xhtml....These are ghc-8.4-bundled packages, removing to avoid build conflicts. * gnu/packages/haskell.scm (ghc-parsec, ghc-stm, ghc-text): Remove. * gnu/packages/haskell-web.scm (ghc-xhtml): Remove. * gnu/packages/agda.scm (agda)[inputs]: Remove ghc-stm and ghc-text. * gnu/packages/bioinformatics.scm (ngless)[inputs]: Remove ghc-parsec and ghc-text. * gnu/packages/haskell-apps.scm (darcs)[inputs]: Remove ghc-parsec. (git-annex)[inputs]: Remove ghc-stm and ghc-text. (ghc-sdl2)[inputs]: Remove ghc-text. (ghc-sdl2-image)[inputs]: Remove ghc-text. * gnu/packages/haskell-check.scm (ghc-tasty-ant-xml)[inputs]: Remove ghc-stm. (ghc-tasty)[inputs]: Remove ghc-stm. (ghc-tasty-rerun)[inputs]: Same. (ghc-quickcheck-instances)[inputs]: Remove ghc-text. (ghc-hedgehog)[inputs]: Remove ghc-stm. * gnu/packages/haskell-crypto.scm (ghc-asn1-encoding)[inputs]: Remove ghc-text. * gnu/packages/haskell-web.scm (ghc-tagsoup)[inputs]: Remove ghc-text. (ghc-cookie)[inputs]: Same. (ghc-http-types)[inputs]: Same. (ghc-http)[inputs]: Remove ghc-parsec. (ghc-http-client)[inputs]: Remove ghc-text. (ghc-http2)[inputs]: Remove ghc-stm. (ghc-http-conduit)[native-inputs]: Remove ghc-text. (ghc-wai)[inputs]: Same. (ghc-wai-extra)[inputs]: Same. (ghc-warp)[inputs]: Remove ghc-stm and ghc-text. (ghc-xss-sanitize)[native-inputs]: Remove ghc-text. (ghc-css-text)[inputs]: Same. (ghc-mime-types)[inputs]: Same. (ghc-blaze-html)[inputs]: Same. (ghc-aeson)[inputs]: Same. (ghc-aeson-pretty)[inputs]: Same. (ghc-aeson-qq)[inputs]: Remove ghc-text and ghc-parsec. (ghc-multipart)[inputs]: Remove ghc-parsec. (ghc-uri-encode)[inputs]: Remove ghc-text. (ghc-path-pieces)[inputs]: Same. (ghc-yesod-core)[inputs]: Remove ghc-text and ghc-parsec. (ghc-yesod-persistent)[inputs]: Remove ghc-text. (ghc-yesod-form)[inputs]: Same. (ghc-yesod)[inputs]: Same. (ghc-hxt-regex-xmlschema)[inputs]: Remove ghc-parsec and ghc-text. (ghc-hxt)[inputs]: Remove ghc-parsec. * gnu/packages/haskell.scm (ghc-convertible)[inputs]: Remove ghc-text. (ghc-double-conversion)[inputs]: Same. (ghc-tree-diff)[inputs]: Remove ghc-parsec and ghc-text. [native-inputs]: Remove ghc-parsec. (ghc-cgi)[inputs]: Remove ghc-parsec. (hlint)[inputs]: Remove ghc-text. (ghc-openglraw)[inputs]: Remove ghc-text. (ghc-opengl)[inputs]: Same. (ghc-streaming-commons)[inputs]: Remove ghc-stm and ghc-text. (ghc-hackage-security)[inputs]: Remove ghc-parsec. (cabal-install)[inputs]: Remove ghc-stm. (ghc-parsec-numbers)[inputs]: Remove ghc-parsec. (ghc-safesemaphore)[inputs]: Remove ghc-stm. (ghc-text-binary)[inputs]: Remove ghc-text. (ghc-hashable)[inputs]: Remove ghc-text. (ghc-transformers-base)[inputs]: Remove ghc-stm. (ghc-indents)[inputs]: Remove ghc-parsec. (ghc-regex-tdfa-rc)[inputs]: Same. (ghc-regex-tdfa-text)[inputs]: Same. (ghc-regex)[inputs]: Remove ghc-text. (ghc-parsers)[inputs]: Remove ghc-parsec and ghc-text. (ghc-attoparsec)[inputs]: Remove ghc-text. (ghc-attoparsec-bootstrap)[inputs]: Same. (ghc-zip-archive)[inputs]: Same. (ghc-polyparse)[inputs]: Same. (ghc-reducers)[inputs]: Same. (ghc-xml)[inputs]: Same. (ghc-feed)[inputs]: Same. (ghc-exceptions)[inputs]: Remove ghc-stm. (ghc-case-insensitive)[inputs]: Remove ghc-text. (ghc-megaparsec)[inputs]: Same. (ghc-network-uri)[inputs]: Remove ghc-parsec. (ghc-monad-control)[inputs]: Remove ghc-stm. (ghc-blaze-builder)[inputs]: Remove ghc-text. (ghc-blaze-markup)[inputs]: Same. (ghc-async)[inputs]: Remove ghc-stm. (ghc-invariant)[inputs]: Same. (ghc-statevar)[inputs]: Same. (ghc-lens)[inputs]: Remove ghc-text. (ghc-cheapskate)[inputs]: Same. (ghc-semigroups)[inputs]: Same. (ghc-semigroups-bootstrap)[inputs]: Same. (ghc-fast-logger)[inputs]: Same. (ghc-scientific)[inputs]: Same. (ghc-scientific-bootstrap)[inputs]: Same. (ghc-texmath)[inputs]: Remove ghc-parsec. (ghc-highlighting-kate)[inputs]: Same. (ghc-cmark)[inputs]: Remove ghc-text. (ghc-cmark-gfm)[inputs]: Same. (ghc-th-lift-instances)[inputs]: Same. (ghc-yaml)[inputs]: Same. (ghc-hslua)[inputs]: Same. (ghc-hslua-module-text)[inputs]: Same. (ghc-skylighting-core)[inputs]: Same. (ghc-doctemplates)[inputs]: Remove ghc-text and ghc-parsec. (ghc-pandoc)[inputs]: Same. (ghc-typed-process)[inputs]: Remove ghc-stm. (ghc-conduit-extra)[inputs]: Remove ghc-stm and ghc-text. (ghc-xml-types)[inputs]: Remove ghc-text. (ghc-xml-conduit)[inputs]: Same. (ghc-pandoc-citeproc)[inputs]: Remove ghc-text and ghc-parsec. (ghc-regex-tdfa)[inputs]: Remove ghc-parsec. (ghc-wl-pprint-text)[inputs]: Remove ghc-text. (ghc-graphviz)[inputs]: Same. (ghc-system-filepath-bootstrap)[inputs]: Same. (ghc-system-fileio-bootstrap)[inputs]: Same. (ghc-shelly)[inputs]: Same. (ghc-chell)[inputs]: Same. (ghc-system-filepath)[inputs]: Same. (ghc-system-fileio)[inputs]: Same. (ghc-fsnotify)[inputs]: Same. (ghc-json)[inputs]: Remove ghc-text and ghc-parsec. (ghc-esqueleto)[inputs]: Remove ghc-text. (shellcheck)[inputs]: Remove ghc-parsec. (ghc-errors)[inputs]: Remove ghc-text. (ghc-chunked-data)[inputs]: Same. (ghc-uuid-types)[inputs]: Same. (ghc-uuid)[inputs]: Same. (ghc-rebase)[inputs]: Remove ghc-stm and ghc-text. (ghc-foldl)[inputs]: Remove ghc-text. (ghc-mono-traversable)[inputs]: Same. (ghc-conduit-combinators)[inputs]: Same. (ghc-aws)[inputs]: Same. (ghc-stm-chans)[inputs]: Remove ghc-stm. (ghc-monad-logger)[inputs]: Remove ghc-text and ghc-stm. (ghc-shakespeare)[inputs]: Remove ghc-parsec and ghc-text. (ghc-resource-pool)[inputs]: Remove ghc-stm. (ghc-attoparsec-iso8601)[inputs]: Remove ghc-text. (ghc-http-api-data)[inputs]: Same. (ghc-persistent)[inputs]: Same. (ghc-aeson-compat)[inputs]: Same. (ghc-persistent-template)[inputs]: Same. (ghc-unliftio)[inputs]: Remove ghc-stm. (ghc-persistent-sqlite)[native-inputs]: Remove ghc-text. (ghc-bytes)[inputs]: Same. (ghc-missingh)[inputs]: Remove ghc-parsec. (ghc-rio)[inputs]: Remove ghc-text. (ghc-cairo)[inputs]: Same. (ghc-atomic-write)[inputs]: Remove ghc-text. [native-inputs]: Same. (ghc-stm-conduit)[inputs]: Remove ghc-stm. (ghc-conduit-algorithms)[inputs]: Same. (ghc-interpolate)[native-inputs]: Remove ghc-text. (ghc-hpack)[inputs]: Same. (ghc-inline-c)[inputs]: Remove ghc-parsec. (ghc-configurator)[inputs]: Remove ghc-text. (ghc-c2hs)[native-inputs]: Same. (ghc-libmpd)[inputs]: Same. (ghc-concurrent-output)[inputs]: Remove ghc-stm. * gnu/packages/idris.scm (idris)[inputs]: Remove ghc-text. * gnu/packages/wm.scm (xmobar)[inputs]: Remove ghc-parsec and ghc-stm. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Robert Vollmert