aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:07:04 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:38 +0200
commit8f710be89e18175e89d73332030b305f434d8883 (patch)
tree93488e8ea8e3a59b8e2d47a1d8365ca480e912b5 /gnu/packages
parent69814c9229f3ae23f8a4484f3385edf1c369f975 (diff)
downloadguix-8f710be89e18175e89d73332030b305f434d8883.tar.gz
guix-8f710be89e18175e89d73332030b305f434d8883.zip
gnu: awesome: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/wm.scm (awesome): Delete trailing #t. [inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I3dd64b3ddc2884bd269ec5d07a58ef8944e848ff
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/wm.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f81f1e0a49..cb9ea62bb0 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1230,7 +1230,8 @@ for wlroots-based Wayland compositors.")
pkg-config
xmlto))
(inputs
- (list cairo
+ (list bash-minimal
+ cairo
dbus
gdk-pixbuf
glib
@@ -1311,8 +1312,7 @@ for wlroots-based Wayland compositors.")
(let* ((out (assoc-ref outputs "out"))
(awesome (string-append out "/bin/awesome")))
(substitute* (string-append out "/share/xsessions/awesome.desktop")
- (("Exec=awesome") (string-append "Exec=" awesome)))
- #t)))
+ (("Exec=awesome") (string-append "Exec=" awesome))))))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((awesome (assoc-ref outputs "out"))
@@ -1325,8 +1325,7 @@ for wlroots-based Wayland compositors.")
`("LUA_CPATH" ";" suffix
(,(format #f "~a/lib/lua/~a/?.so" lua-lgi lua-version)))
`("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH")))
- `("LD_LIBRARY_PATH" suffix (,cairo)))
- #t))))))
+ `("LD_LIBRARY_PATH" suffix (,cairo)))))))))
(home-page "https://awesomewm.org/")
(synopsis "Highly configurable window manager")
(description