aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-13 23:08:14 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:53 +0100
commit8b1d7742725aef814118198d26ab097295021189 (patch)
tree762bdd4eabed55fa80d653bf3a30ebe4bb27c3a1 /gnu/packages
parent5e1b47b8ad5f4a34d810e259737427f4b74d0dc5 (diff)
downloadguix-8b1d7742725aef814118198d26ab097295021189.tar.gz
guix-8b1d7742725aef814118198d26ab097295021189.zip
gnu: gopls: Update to 0.13.2.
* gnu/packages/golang.scm (gopls): Update to 0.13.2. [propagated-inputs]: Remove go-github-com-burntsushi-toml, go-github-com-google-safehtml, and go-golang-org-x-exp; add go-golang-org-x-tools. Change-Id: I9c9b34151749d04974c526e1eca2a6f4846e226f
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 50805467d1..beafe30e6d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3216,7 +3216,9 @@ the @url{https://vuln.go.dev,Go Vulnerability Database}.")
(define-public gopls
(package
(name "gopls")
- (version "0.12.0")
+ ;; XXX: Starting from 0.14.0 gppls needs golang.org/x/telemetry, which
+ ;; needs to be discussed if it may be included in Guix.
+ (version "0.13.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3225,7 +3227,7 @@ the @url{https://vuln.go.dev,Go Vulnerability Database}.")
(file-name (git-file-name name version))
(sha256
(base32
- "04bq7rh6d6mgxm0lsi8y9v1x7cgx4nvjlsyvxl89r6rcqh3n1lfb"))))
+ "1qym2c0xvv6vcgwh0kz8sw094r88lzrl08xpvmg08lrqi00ma6kx"))))
(build-system go-build-system)
(arguments
`(#:import-path "golang.org/x/tools/gopls"
@@ -3243,13 +3245,11 @@ the @url{https://vuln.go.dev,Go Vulnerability Database}.")
go-golang-org-x-sync
go-golang-org-x-sys
go-golang-org-x-text
+ go-golang-org-x-tools
+ go-golang-org-x-vuln
go-gopkg-in-yaml-v3
go-honnef-co-go-tools
- go-github-com-burntsushi-toml
- go-github-com-google-safehtml
- go-golang-org-x-exp
go-mvdan-cc-gofumpt
- go-golang-org-x-vuln
go-mvdan-cc-xurls))
(home-page "https://golang.org/x/tools/gopls")
(synopsis "Official language server for the Go language")