aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-08-12 20:26:25 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-21 14:05:28 +0100
commit88c4c0fd69816d5f90b3b28e197b3c142b265204 (patch)
tree04eb4d9c9e6ebc687333da6e86710fbb1bdbf069 /gnu/packages
parent1c69f719affc6957e4c69960fa49d359d1b5e659 (diff)
downloadguix-88c4c0fd69816d5f90b3b28e197b3c142b265204.tar.gz
guix-88c4c0fd69816d5f90b3b28e197b3c142b265204.zip
gnu: Add go-github-com-mattbaird-jsonpatch.
* gnu/packages/golang-web.scm (go-github-com-mattbaird-jsonpatch): New variable. Change-Id: I571c51f2141dbba53067f4279003a4604f21b1a4 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c9d755f606..7b399ca401 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2271,6 +2271,38 @@ clients that speak the Gemini protocol.")
@@url{https://github.com/makeworld-the-better-one/go-gemini,go-gemini}.")
(license license:expat)))
+(define-public go-github-com-mattbaird-jsonpatch
+ (package
+ (name "go-github-com-mattbaird-jsonpatch")
+ (version "0.0.0-20240118010651-0ba75a80ca38")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mattbaird/jsonpatch")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nxbrpk8bvvmfgl4sfsbx82g0q44i2sakl7vigbsj3prx6nql5iv"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mattbaird/jsonpatch"))
+ (native-inputs
+ (list go-github-com-evanphx-json-patch go-github-com-stretchr-testify))
+ (home-page "https://github.com/mattbaird/jsonpatch")
+ (synopsis "JSON Patch library for Go")
+ (description
+ "@url{http://jsonpatch.com/, JSON Patch} implementation for Go as
+specified in @url{https://datatracker.ietf.org/doc/html/rfc6902/, RFC 6902}
+from the IETF.
+
+JSON Patch allows you to generate JSON that describes changes you want to make
+to a document, so you don't have to send the whole doc. JSON Patch format is
+supported by HTTP PATCH method, allowing for standards based partial updates
+via REST APIs.")
+ (license license:asl2.0)))
+
(define-public go-github-com-microcosm-cc-bluemonday
(package
(name "go-github-com-microcosm-cc-bluemonday")