aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-22 16:45:43 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:29 +0000
commit860f7ad11b60d553219d03cab1a4675410a9633d (patch)
tree65417c0fab68eba3484a7b71255e4071df1af518 /gnu/packages
parente190cfa13f6762a6499dd623c85393b63c1ce511 (diff)
downloadguix-860f7ad11b60d553219d03cab1a4675410a9633d.tar.gz
guix-860f7ad11b60d553219d03cab1a4675410a9633d.zip
gnu: python-pylint: Update to 3.3.1.
* gnu/packages/check.scm (python-pylint): Update to 3.3.1. Refresh package style. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Use default 'check phase. Add 'set-home phase. <test-flags>: Move test selection/exclusion logic here. [native-inputs]: Add python-pytest-timeout, python-setuptools, and python-wheel. Change-Id: I2cde539f5f29a23d4037232937e419bbfd47d372
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm41
1 files changed, 26 insertions, 15 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 836432786b..dc5c0a8830 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3176,7 +3176,7 @@ statements in the module it tests.")
(define-public python-pylint
(package
(name "python-pylint")
- (version "2.14.5")
+ (version "3.3.1")
(source
(origin
(method git-fetch)
@@ -3185,23 +3185,34 @@ statements in the module it tests.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0ljfvyzr2i07pi7m19kbshlc3cfnwr53mjhcpydaa0w8bak4cc95"))))
- (build-system python-build-system)
+ (base32 "023cd6gqhhykr1gf8w7nxs5n7qgqwwsd4mgn94r14is8gcf1hwvj"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
+ (list
+ #:test-flags
+ #~(list "--numprocesses" (number->string (parallel-job-count))
+ "-W" "ignore::DeprecationWarning"
+ "--ignore=tests/benchmark"
;; The unused but collected 'primer'-related test files require
- ;; the extraneous 'git' Python module; remove them.
- (delete-file "tests/primer/test_primer_external.py")
- (delete-file "tests/testutils/test_package_to_lint.py")
- (setenv "HOME" "/tmp")
- (invoke "pytest" "-k" "test_functional"
- "-n" (number->string (parallel-job-count)))))))))
+ ;; the extraneous 'git' Python module; ignore them.
+ "--ignore=tests/testutils/_primer/test_package_to_lint.py"
+ "--ignore=tests/testutils/_primer/test_primer.py"
+ "-k" (string-join
+ ;; Test failing with multiple assertion errors.
+ (list "not test_functional"
+ "test_functional_relation_extraction")
+ " and not "))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-home
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
(native-inputs
- (list python-pytest python-pytest-xdist))
+ (list python-pytest
+ python-pytest-timeout
+ python-pytest-xdist
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-astroid
python-dill