aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-26 20:43:45 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:28:38 +0000
commit8596af6b0de67851c06a65b1202d86e9d366fcae (patch)
tree37f8bf7e3060893fe881bbfedf0a9e3a8ef1e636 /gnu/packages
parent9d106932e057db1aa9b6945d61c11b5fc031342c (diff)
downloadguix-8596af6b0de67851c06a65b1202d86e9d366fcae.tar.gz
guix-8596af6b0de67851c06a65b1202d86e9d366fcae.zip
gnu: python-slotscheck: Update to 0.19.0.
* gnu/packages/python-check.scm (python-slotscheck): Update to 0.19.0. Improve package style. [source]{url}: Use direct string of URL instead of home-page field. [native-inputs]: Remove python-pydantic; add python-ujson. Change-Id: I9ea14cb694f9dd7e3330b9f8e015621053d70d0b
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-check.scm33
1 files changed, 20 insertions, 13 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index fa5c2f4af0..1e859d5d16 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2481,23 +2481,30 @@ behavior-driven development (TDD and BDD).")
(define-public python-slotscheck
(package
(name "python-slotscheck")
- (version "0.17.0")
- (home-page "https://github.com/ariebovenberg/slotscheck")
- (source (origin
- (method git-fetch)
- (uri (git-reference (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0k5jjabd219ndlssfqcdb5sn891ffrxzw84l5r8pirzy74i7znr4"))))
+ (version "0.19.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ariebovenberg/slotscheck")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lakwgk20aq92sqdwsswnll2w3y6p42x8abb9q8fc2qvw3xhw2vh"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; Optional: ModuleNotFoundError: No module named 'mypyc'
+ #:test-flags #~(list "-k" "not test_extension_package")))
(native-inputs
(list python-poetry-core
- python-pydantic
python-pytest
- python-pytest-mock))
- (propagated-inputs (list python-click python-tomli))
+ python-pytest-mock
+ python-ujson))
+ (propagated-inputs
+ (list python-click
+ python-tomli))
+ (home-page "https://github.com/ariebovenberg/slotscheck")
(synopsis "Ensure @code{__slots__} are working properly")
(description
"@code{slotscheck} is a tool to validate Python class @code{__slots__}.")