aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 20:53:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:36 +0200
commit8418976b0f83765455603f17e55b55e9a47f6a4c (patch)
treebdc991e0641883f62b08920c5cec82ddb4b25a33 /gnu/packages
parentab021b964a3dcca07e241542a0f4de780d4cb99d (diff)
downloadguix-8418976b0f83765455603f17e55b55e9a47f6a4c.tar.gz
guix-8418976b0f83765455603f17e55b55e9a47f6a4c.zip
gnu: texlive-iftex: Refresh package definition.
* gnu/packages/tex.scm (texlive-iftex): Remove SIMPLE-TEXLIVE-PACKAGE call.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm39
1 files changed, 21 insertions, 18 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 73942d3de9..91c0c11c5d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10535,24 +10535,27 @@ frames made with the @code{framed} package.")
(license license:lppl1.3c+))))
(define-public texlive-iftex
- (let ((template (simple-texlive-package
- "texlive-iftex"
- (list "/doc/generic/iftex/"
- "/tex/generic/iftex/")
- (base32
- "147xa5kl4kjs05nj8v3kd7dpr5xkz3xp3gdvjih32ccd7527f5vp")
- #:trivial? #t)))
- (package
- (inherit template)
- (home-page "http://www.ctan.org/pkg/iftex")
- (synopsis "Determine the currently used TeX engine")
- (description "This package, which works both for Plain TeX and for
-LaTeX, defines the @code{\\ifPDFTeX}, @code{\\ifXeTeX}, and @code{\\ifLuaTeX}
-conditionals for testing which engine is being used for typesetting. The
-package also provides the @code{\\RequirePDFTeX}, @code{\\RequireXeTeX}, and
-@code{\\RequireLuaTeX} commands which throw an error if pdfTeX, XeTeX or
-LuaTeX (respectively) is not the engine in use.")
- (license license:lppl1.3+))))
+ (package
+ (name "texlive-iftex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "/doc/generic/iftex/"
+ "/tex/generic/iftex/")
+ (base32
+ "147xa5kl4kjs05nj8v3kd7dpr5xkz3xp3gdvjih32ccd7527f5vp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "http://www.ctan.org/pkg/iftex")
+ (synopsis "Determine the currently used TeX engine")
+ (description
+ "This package, which works both for Plain TeX and for LaTeX, defines the
+@code{\\ifPDFTeX}, @code{\\ifXeTeX}, and @code{\\ifLuaTeX} conditionals for
+testing which engine is being used for typesetting. The package also provides
+the @code{\\RequirePDFTeX}, @code{\\RequireXeTeX}, and @code{\\RequireLuaTeX}
+commands which throw an error if pdfTeX, XeTeX or LuaTeX (respectively) is not
+the engine in use.")
+ (license license:lppl1.3+)))
(define-deprecated-package texlive-generic-iftex texlive-iftex)