aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-05-14 17:26:46 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:02 +0200
commit839285dd5b2980cb9feaacb22c6c43565deeb6e2 (patch)
treeb5040ae129db0d6f8133cd5e0cad08db71fa72f9 /gnu/packages
parentce7794992da301f08a6c5d41aa12c2a1e4242397 (diff)
downloadguix-839285dd5b2980cb9feaacb22c6c43565deeb6e2.tar.gz
guix-839285dd5b2980cb9feaacb22c6c43565deeb6e2.zip
gnu: Avoid cycle involving (gnu packages pkg-config).
Fixes a regression introduced in 7a26aee61bbbd8e37745ce13433545333eac4505 whereby (gnu packages pkg-config) would be caught in a cycle, leading to miscompilation of package modules, in turn leading to failure to compute the Guix derivation with exceptions like: 1. &package-input-error: package: #<package libgc@8.2.4 7fee96c4dc60> input: ("_" #<syntax-transformer pkg-config>) * gnu/packages/pkg-config.scm: Autoload (gnu packages check). Change-Id: I624e701a0c411b6f3d9ad5e10dca6ad7cf552be4
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/pkg-config.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/pkg-config.scm b/gnu/packages/pkg-config.scm
index d1c6c644ac..d5655bd893 100644
--- a/gnu/packages/pkg-config.scm
+++ b/gnu/packages/pkg-config.scm
@@ -29,7 +29,13 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (gnu packages bash)
- #:use-module (gnu packages check)
+
+ ;; Note: Because this module defines the 'pkg-config' macro, it cannot be
+ ;; caught in a cycle with other package modules or the macro wouldn't be
+ ;; visible at the time those other modules are compiled. To fulfill that
+ ;; constraint, load (gnu packages check) lazily.
+ #:autoload (gnu packages check) (atf kyua)
+
#:use-module (guix memoization)
#:export (pkg-config))