aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKabelo M'sobomvu Moiloa <personal@kabelom.com>2023-09-06 18:44:02 +0200
committerAndrew Tropin <andrew@trop.in>2023-09-07 16:49:46 +0400
commit811f4fc509a57ff14b1dd03d76fea66085e3f5e1 (patch)
treee3ee871f811ca63b4298ee24bf7b165b7d6c1181 /gnu/packages
parent33a0a80702ca8b8d45c6172a530a304c1f97e52a (diff)
downloadguix-811f4fc509a57ff14b1dd03d76fea66085e3f5e1.tar.gz
guix-811f4fc509a57ff14b1dd03d76fea66085e3f5e1.zip
gnu: emacs-consult-eglot: Update 0.2.0-0.db9d41c.
* gnu/packages/emacs-xyz.scm (emacs-consult-eglot): Update 0.2.0-0.db9d41c. Signed-off-by: Andrew Tropin <andrew@trop.in> Co-authored-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm37
1 files changed, 20 insertions, 17 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f0a9cecb9c..baa67eefbb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11581,25 +11581,28 @@ versions utilizing Consult's internal API.")
(license license:gpl3+))))
(define-public emacs-consult-eglot
- (package
- (name "emacs-consult-eglot")
- (version "0.2.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mohkale/consult-eglot")
- (commit (string-append "v" version))))
- (sha256
- (base32 "1qxk1npxbf8m3g9spikgdxcf6mzjx6cwy3f5vn6zz5ksh14xw3sd"))
- (file-name (git-file-name name version))))
- (build-system emacs-build-system)
- (propagated-inputs (list emacs-consult emacs-eglot))
- (home-page "https://github.com/mohkale/consult-eglot")
- (synopsis "Consulting-read interface for eglot")
- (description "This package acts as a parallel of consult-lsp for eglot and
+ (let ((revision "0")
+ (commit "db9d41c9812a5a8a7b9a22fa7f3c314e37584d41"))
+ (package
+ (name "emacs-consult-eglot")
+ (version (git-version "0.2.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mohkale/consult-eglot")
+ (commit commit)))
+ (sha256
+ (base32
+ "1xcv9lj4r9s584gfkbqi9dmi045a3phb2x63fzfd7vpdy15xg47n"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-consult emacs-eglot))
+ (home-page "https://github.com/mohkale/consult-eglot")
+ (synopsis "Consulting-read interface for eglot")
+ (description "This package acts as a parallel of consult-lsp for eglot and
provides a front-end interface for the workspace/symbols LSP procedure
call.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-consult-flycheck
;; This particular commit introduces bug fixes above latest release.
Turns out it's easier to read. * tests/cpan.scm ("cpan->guix-package"): Use a quasiquoted pattern. * tests/elpa.scm (eval-test-with-elpa): Likewise. * tests/gem.scm ("gem->guix-package") ("gem->guix-package with a specific version") ("gem-recursive-import") ("gem-recursive-import with a specific version"): Likewise. * tests/hexpm.scm ("hexpm-recursive-import"): Likewise. * tests/opam.scm ("opam->guix-package"): Likewise. * tests/pypi.scm ("pypi->guix-package, no wheel") ("pypi->guix-package, wheels") ("pypi->guix-package, no usable requirement file.") ("pypi->guix-package, package name contains \"-\" followed by digits"): Likewise. * tests/texlive.scm ("texlive->guix-package"): Likewise. Ludovic Courtès 2023-04-19tests: Fix texlive->guix-package test....The home page for the package had changed. * tests/texlive.scm ("texlive->guix-package"): Match the home-page and synopsis inexactly to avoid future similar breakages. Maxim Cournoyer 2022-07-22tests: Adjust texlive importer tests....This is a follow-up to commit be7b314f3fe22273e935accac22f313e44d3d970. * tests/texlive.scm: Add version field to expected output. Ricardo Wurmus 2022-01-13import: texlive: Remove labels from 'propagated-inputs' field....* guix/import/texlive.scm (tlpdb->package): Remove labels from 'propagated-inputs' field. * tests/texlive.scm ("texlive->guix-package"): Adjust accordingly. Ludovic Courtès 2022-01-11tests: Fix texlive test by sorting locations....* tests/texlive.scm ("texlive->guix-package"): Correct order of locations. Ricardo Wurmus 2021-11-18tests: Replace texlive importer tests....* tests/texlive.scm (xml, sxml): Remove variables. ("fetch-sxml: returns SXML for valid XML", "sxml->package"): Remove tests. ("texlive->guix-package"): Add new test. Ricardo Wurmus 2021-03-06tests: do not hard code HTTP ports...Previously, test cases could fail if some process was listening at a hard-coded port. This patch eliminates most of these potential failures, by automatically assigning an unbound port. This should allow for building multiple guix trees in parallel outside a build container, though this is currently untested. The test "home-page: Connection refused" in tests/lint.scm still hardcodes port 9999, however. * guix/tests/http.scm (http-server-can-listen?): remove now unused procedure. (%http-server-port): default to port 0, meaning the OS will automatically choose a port. (open-http-server-socket): remove the false statement claiming this procedure is exported and also return the allocated port number. (%local-url): raise an error if the port is obviously unbound. (call-with-http-server): set %http-server-port to the allocated port while the thunk is called. * tests/derivations.scm: adjust test cases to use automatically assign a port. As there is no risk of a port conflict now, do not make any tests conditional upon 'http-server-can-listen?' anymore. * tests/elpa.scm: likewise. * tests/lint.scm: likewise, and add a TODO comment about a port that is still hard-coded. * tests/texlive.scm: likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Maxime Devos 2020-01-17import: texlive: Avoid uses of '@@' in tests....* guix/import/texlive.scm (fetch-sxml, sxml->package): Export. * tests/texlive.scm <top level>: Call '%http-server-port'. ("fetch-sxml: returns SXML for valid XML"): Use 'with-http-server' and set 'current-http-proxy' instead of using 'mock'. ("sxml->package"): Remove use of '@@'. Ludovic Courtès