aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2024-08-21 21:37:39 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:46 +0100
commit7ff7ca4b700c61cd6ae5f83058897d3bbb3a22aa (patch)
tree6ecc55c65d24b6f531b91a20c8cba80943ebe638 /gnu/packages
parent1c8451d0bab3429d176a89fa1ebf3264bdf8fd95 (diff)
downloadguix-7ff7ca4b700c61cd6ae5f83058897d3bbb3a22aa.tar.gz
guix-7ff7ca4b700c61cd6ae5f83058897d3bbb3a22aa.zip
gnu: Add go-github-com-shurcool-httpgzip.
* gnu/packages/golang-web.scm (go-github-com-shurcool-httpgzip): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I78255b1729587c99ba1bbb6c8759d55d00c83497
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index a52e02cf6d..c252470815 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3605,6 +3605,34 @@ of the specification.")
support.")
(license license:expat)))
+(define-public go-github-com-shurcool-httpgzip
+ (package
+ (name "go-github-com-shurcool-httpgzip")
+ (version "0.0.0-20230704072819-d1585fc322fa")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shurcooL/httpgzip")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10fnndia8ij3hwwvknn8qy8z3955bm7xyvqd69yh5g2zh25zc5x2"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/shurcooL/httpgzip"))
+ (native-inputs
+ (list go-golang-org-x-tools))
+ (propagated-inputs
+ (list go-golang-org-x-net))
+ (home-page "https://github.com/shurcooL/httpgzip")
+ (synopsis "Primitives of @code{net-http}-like with gzip compression")
+ (description
+ "Package @code{httpgzip} provides @code{net/http}-like primitives that
+use gzip compression when serving HTTP requests.")
+ (license license:expat)))
+
(define-public go-github-com-sourcegraph-jsonrpc2
(package
(name "go-github-com-sourcegraph-jsonrpc2")