aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSuhail Singh <suhailsingh247@gmail.com>2024-10-29 23:15:05 -0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-11-15 07:46:07 +0100
commit7e25d04228b0b2b03d4619e74c23264947d37619 (patch)
treefa4ab2b44501a193f375ec71f9d1111ddc6a8b1c /gnu/packages
parentf5f4978ec3cccc23357fdadb0bdbc3e16e7765d1 (diff)
downloadguix-7e25d04228b0b2b03d4619e74c23264947d37619.tar.gz
guix-7e25d04228b0b2b03d4619e74c23264947d37619.zip
gnu: Add emacs-jack.
* gnu/packages/emacs-xyz.scm (emacs-jack): New variable. Change-Id: I92790c493016a312501e926bbfc4b274d954e26f Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 90a2637bde..68532d0c4b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11337,6 +11337,39 @@ features like jumping to definitions, finding references, and viewing
documentation, enhancing the Python development experience within Emacs.")
(license license:gpl3+))))
+(define-public emacs-jack
+ (let ((commit "3b4ea97fcc107d0ffd201ea695129af52f390113")
+ (revision "0"))
+ (package
+ (name "emacs-jack")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tonyaldon/jack")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cizszj62ic41zc97glf2mdvm1kd95vdfg2dip3n2p2g0nlk2hjf"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:tests? #t
+ #:test-command #~(list "emacs"
+ "--batch"
+ "-l"
+ "jack-tests.el"
+ "-f"
+ "ert-run-tests-batch-and-exit")))
+ (home-page "https://jack.tonyaldon.com")
+ (synopsis "HTML generator library")
+ (description
+ "@code{jack} provides the function @code{jack-html} that takes a data
+structure as input representing the HTML tree you want to generate and
+generates it as a string. Please see the homepage for usage examples.")
+ (license license:gpl3+))))
+
(define-public emacs-jedi
(package
(name "emacs-jedi")