aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-14 23:23:14 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:47 +0000
commit7dfeace19871621fa69923677cd23383f36d81d8 (patch)
tree1844b3ba1d211cba353e1533e2fb0673fc2137ed /gnu/packages
parent956a449b44b05dc7c440ce4ff333bd089a806c3e (diff)
downloadguix-7dfeace19871621fa69923677cd23383f36d81d8.tar.gz
guix-7dfeace19871621fa69923677cd23383f36d81d8.zip
gnu: Add go-github-com-muesli-combinator.
* gnu/packages/golang-xyz.scm (go-github-com-muesli-combinator): New variable. Change-Id: I24e9c6c752e677d6c3f4f97f461bbd66d7b675b1
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 48b71aa71b..df2132eb52 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5335,6 +5335,31 @@ Authentication Modules, PAM} application API.")
"This package provides a cancelable reader for Go.")
(license license:expat)))
+(define-public go-github-com-muesli-combinator
+ (package
+ (name "go-github-com-muesli-combinator")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/muesli/combinator")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rjw1rl1v38pn6lmyaz7yhgrwkyh22d6974lj33x1c86q0xpaw4d"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/muesli/combinator"))
+ (home-page "https://github.com/muesli/combinator")
+ (synopsis "Cancelable reader for Go")
+ (description
+ "@code{combinator} generates a slice of all possible value combinations
+for any given struct and a set of its potential member values. This can be
+used to generate extensive test matrixes among other things.")
+ (license license:expat)))
+
(define-public go-github-com-muesli-reflow
(package
(name "go-github-com-muesli-reflow")