aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRemco van 't Veer <remco@remworks.net>2024-09-02 21:38:25 +0200
committerAndrew Tropin <andrew@trop.in>2024-09-05 19:04:42 +0400
commit7d2ced8d6d9c38327592d312376d59a8c37fc160 (patch)
treeb1762280bd08163540559cfb81b8418e4bc08936 /gnu/packages
parent993d6d2e7be4dac738629c76a51058f4dc5bc449 (diff)
downloadguix-7d2ced8d6d9c38327592d312376d59a8c37fc160.tar.gz
guix-7d2ced8d6d9c38327592d312376d59a8c37fc160.zip
gnu: python-gst: Fix build.
* gnu/packages/glib.scm: Add package python-pygobject-3.48. * gnu/packages/gstreamer.scm (python-gst) [inputs]: Use python-pygobject-3.48 to fix tests. Change-Id: I3038b85db67ff354a6d77708fa4fd7c63aa6732c Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/glib.scm15
-rw-r--r--gnu/packages/gstreamer.scm3
2 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 9827856f32..d6275ea63e 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 Remco van 't Veer <remco@remworks.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1077,6 +1078,20 @@ useful for C++.")
'((upstream-name . "pygobject")))
(license license:lgpl2.1+)))
+(define-public python-pygobject-3.48
+ (package
+ (inherit python-pygobject)
+ (version "3.48.2")
+ (source
+ (origin
+ (inherit (package-source python-pygobject))
+ (uri (string-append "mirror://gnome/sources/pygobject/"
+ (version-major+minor version)
+ "/pygobject-" version ".tar.xz"))
+ (sha256
+ (base32
+ "19yii8lydnjw225k4gclhn8hya7caiginqi0mj9a0cdym6sax507"))))))
+
(define-public perl-glib
(package
(name "perl-glib")
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index ad08285181..66978fc2bc 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2024 Remco van 't Veer <remco@remworks.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1126,7 +1127,7 @@ binary, but none of the actual plugins.")))
(native-inputs
(list pkg-config python))
(propagated-inputs
- (list gst-plugins-base python-pygobject))
+ (list gst-plugins-base python-pygobject-3.48))
(home-page "https://gstreamer.freedesktop.org/")
(synopsis "GStreamer GObject Introspection overrides for Python")
(description