aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish.is@lostca.se>2024-09-25 15:49:06 +0200
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-27 19:08:05 +0800
commit7c840b206383cae324da8c2fd593786f43642fc5 (patch)
treee66d178050dd53560cc50f704c604ef8c609b6b9 /gnu/packages
parent2c6113cbc7c22969c9789ef892a27eca674c0d3f (diff)
downloadguix-7c840b206383cae324da8c2fd593786f43642fc5.tar.gz
guix-7c840b206383cae324da8c2fd593786f43642fc5.zip
gnu: fuzzel: Update to 1.11.0.
* gnu/packages/xdisorg.scm (fuzzel): Update to 1.11.0. [sources](origin)<patches>: Add patch. * gnu/packages/patches/fuzzel-fix-gcc-error.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. Change-Id: I7ed41e6b23657833369f9d319c22421161559dc7 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/fuzzel-fix-gcc-error.patch42
-rw-r--r--gnu/packages/xdisorg.scm6
2 files changed, 46 insertions, 2 deletions
diff --git a/gnu/packages/patches/fuzzel-fix-gcc-error.patch b/gnu/packages/patches/fuzzel-fix-gcc-error.patch
new file mode 100644
index 0000000000..4b5071e0e2
--- /dev/null
+++ b/gnu/packages/patches/fuzzel-fix-gcc-error.patch
@@ -0,0 +1,42 @@
+From 05b16745a1d26c4e098c39a49c56e9c312771bd2 Mon Sep 17 00:00:00 2001
+From: Ashish SHUKLA <ashish.is@lostca.se>
+Date: Mon, 23 Sep 2024 12:43:37 +0200
+Subject: [PATCH] Fix release build with GCC 11.x
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+meson in release build mode (with GCC) triggers following compiler error:
+
+ In file included from ../source/clipboard.c:14:
+ ../source/clipboard.c: In function ‘select_mime_type_for_offer’:
+ ../source/log.h:58:5: error: ‘%s’ directive argument is null [-Werror=format-overflow=]
+ 58 | log_msg(LOG_CLASS_DEBUG, LOG_MODULE, __FILE__, __LINE__, fmt, ## __VA_ARGS__)
+ | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ ../source/clipboard.c:81:5: note: in expansion of macro ‘LOG_DBG’
+ 81 | LOG_DBG("mime-type: %s -> %s (offered type was %s)",
+ | ^~~~~~~
+ ../source/clipboard.c:81:31: note: format string is defined here
+ 81 | LOG_DBG("mime-type: %s -> %s (offered type was %s)",
+ | ^~
+
+Fixes #420
+---
+ clipboard.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/clipboard.c b/clipboard.c
+index a4fa2d2..c692503 100644
+--- a/clipboard.c
++++ b/clipboard.c
+@@ -79,7 +79,9 @@ select_mime_type_for_offer(const char *_mime_type,
+ }
+
+ LOG_DBG("mime-type: %s -> %s (offered type was %s)",
+- mime_type_map[*type], mime_type_map[mime_type], _mime_type);
++ mime_type_map[*type],
++ (mime_type_map[mime_type] == NULL ? "(null)" : mime_type_map[mime_type]),
++ _mime_type);
+
+ /* Mime-type transition; if the new mime-type is "better" than
+ * previously offered types, use the new type */
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 00f99ec4a8..59822fff7b 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3424,7 +3424,7 @@ using @command{dmenu}.")
(define-public fuzzel
(package
(name "fuzzel")
- (version "1.10.2")
+ (version "1.11.0")
(home-page "https://codeberg.org/dnkl/fuzzel")
(source (origin
(method git-fetch)
@@ -3432,7 +3432,9 @@ using @command{dmenu}.")
(file-name (git-file-name name version))
(sha256
(base32
- "024gnddvabf5dwkdffr6qnnia810w1jqn4ll9fvbcaimybgpvs13"))))
+ "1z4n1i9rdhfcmfsvb5bvsqy8x8fg51kfiakyqnp200n1nl0kd9ll"))
+ (patches
+ (search-patches "fuzzel-fix-gcc-error.patch"))))
(build-system meson-build-system)
(arguments
(list #:build-type "release"