aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-31 08:43:40 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 17:03:07 +0100
commit7bbbe0338717505b362b60b0e44406769ae50c28 (patch)
tree65f09009ffcc5d9bf6e275178ec354db03d5d05a /gnu/packages
parent67875a4d560bdff2c610b3baa9c8c1fcb153ea87 (diff)
downloadguix-7bbbe0338717505b362b60b0e44406769ae50c28.tar.gz
guix-7bbbe0338717505b362b60b0e44406769ae50c28.zip
gnu: python-reproject: Update to 0.14.0.
* gnu/packages/astronomy.scm (python-reproject): Update to 0.14.0. [propagated-inputs]: Remove python-click. [native-inputs]: Remove python-pytest; add python-asdf, python-gwcs and python-pyvo. Change-Id: If3434c59635fb818923f1bc7e292d494166d50be
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/astronomy.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index e505b4abcb..a9dd4360c4 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3119,13 +3119,13 @@ PSF} describing how the optical system spreads light from sources.")
(define-public python-reproject
(package
(name "python-reproject")
- (version "0.13.1")
+ (version "0.14.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "reproject" version))
(sha256
- (base32 "1xk809h2j3zj37l5lx4l87zanf9zxbxajcrff2b2f2i0jpnmxqv3"))))
+ (base32 "1h5v74da32ai9dkhcdn3xx4h05awlxhhnrsdjj1sb644c1vlyg6x"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -3162,7 +3162,6 @@ setup(ext_modules=get_extensions())")))))
(list python-asdf
python-astropy
python-astropy-healpix
- python-click
python-cloudpickle
python-dask
python-fsspec
@@ -3175,9 +3174,11 @@ setup(ext_modules=get_extensions())")))))
(native-inputs
(list python-cython-3
python-extension-helpers
- python-pytest
+ python-asdf
+ python-gwcs
python-pytest-astropy
python-pytest-xdist
+ python-pyvo
;; python-sunpy ; circular dependencies, test optional
python-setuptools-scm))
(home-page "https://reproject.readthedocs.io")