aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-12-24 22:35:26 +0800
committerLudovic Courtès <ludo@gnu.org>2018-12-26 18:40:49 +0100
commit7ba2b27467a39956f10e2e11061d9569e4b7d632 (patch)
treecc0e11749a54a93916e6e96914f2b4538f386a2a /gnu/packages
parent0ef595b99689a4d80521abd87fa893695c7f75df (diff)
downloadguix-7ba2b27467a39956f10e2e11061d9569e4b7d632.tar.gz
guix-7ba2b27467a39956f10e2e11061d9569e4b7d632.zip
gnu: Add badvpn.
* gnu/packages/vpn.scm (badvpn): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/vpn.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 1edd1ac56a..dabf84a947 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (gnu packages)
@@ -37,6 +39,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gnuzilla)
#:use-module (gnu packages libevent)
#:use-module (gnu packages linux)
#:use-module (gnu packages perl)
@@ -400,3 +403,47 @@ DNS domain name queries.")
@command{sshuttle} virtual private networks. It supports flexible profiles
with configuration options for most of @command{sshuttle}’s features.")
(license license:gpl3+)))
+
+(define-public badvpn
+ (package
+ (name "badvpn")
+ (version "1.999.130")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ambrop72/badvpn.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rm67xhi7bh3yph1vh07imv5y1pwyldvw3wa5bz471g8mnkc7d3c"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ; no tests
+ (inputs
+ `(("nspr" ,nspr)
+ ("nss" ,nss)
+ ("openssl" ,openssl)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/ambrop72/badvpn")
+ (synopsis "Peer-to-peer virtual private network (VPN)")
+ (description "@code{BadVPN} is a collection of virtual private
+network (VPN) tools. It includes:
+
+@enumerate
+@item NCD programming language.\n
+NCD (Network Configuration Daemon) is a daemon and programming/scripting
+language for configuration of network interfaces and other aspects of the
+operating system.
+@item Tun2socks network-layer proxifier.\n
+The tun2socks program socksifes TCP connections at the network layer. It
+implements a TUN device which accepts all incoming TCP connections (regardless
+of destination IP), and forwards the connections through a SOCKS server.
+@item Peer-to-peer VPN.\n
+The peer-to-peer VPN implements a Layer 2 (Ethernet) network between the peers
+(VPN nodes).
+@end enumerate")
+ ;; This project contains a bundled lwIP. lwIP is also released under the
+ ;; 3-clause BSD license.
+ (license license:bsd-3)))
55535ee Signed-off-by: Ludovic Courtès <ludo@gnu.org> Tomas Volf 2023-11-22gnu: aria2: Unbundle wslay....* gnu/packages/bittorrent.scm (aria2)[source]: Add snippet to delete configure script and remove bundled dependency. Add a patch. [native-inputs]: Add autoconf, automake, gettext-minimal, libtool. [inputs]: Add wslay. * gnu/packages/patches/aria2-unbundle-wslay.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I92390a872454726ff9587518bb535d2105c44ef3 Efraim Flashner 2023-11-22gnu: aria2: Update to 1.37.0....* gnu/packages/bittorrent.scm (aria2): Update to 1.37.0. Change-Id: Iddaeabb59b774b61610722f485c8c773aaf60434 Efraim Flashner 2023-10-30gnu: transmission: Update to 4.0.4....* gnu/packages/bittorrent.scm (transmission): Update to 4.0.4. [synopsis]: Remove "marketing phrases". Change-Id: Ibecdf14198ba926eea66ff5ba29ec05fbd27fde2 Signed-off-by: Christopher Baines <mail@cbaines.net> Leo Famulari 2023-09-24gnu: qbittorrent-enhanced: Update to 4.5.5.10....* gnu/packages/bittorrent.scm (qbittorrent-enhanced): Update to 4.5.5.10. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Hilton Chain via Guix-patches via 2023-09-24gnu: qbittorrent-nox: Rename to qbittorrent-no-x....* gnu/packages/bittorrent.scm (qbittorrent-no-x): New variable, renamed from… (qbittorrent-nox): …this package, now redefined as a DEPRECATED-PACKAGE. Tobias Geerinckx-Rice 2023-09-24gnu: qbittorrent: Update to 4.5.5....* gnu/packages/bittorrent.scm (qbittorrent): Update to 4.5.5. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Hilton Chain 2023-09-27gnu: transmission: Fix loading icons in pure environments....* gnu/packages/bittorrent.scm (transmission)[arguments]: Add a 'wrap-program' phase that sets GDK_PIXBUF_MODULE_FILE. Clément Lassieur 2023-09-26gnu: transmission: Restore HTML files in the default output....This fixes transmission-daemon. * gnu/packages/bittorrent.scm (transmission)[arguments]: remove "transmission" directory from the 'move-gui' procedure. Clément Lassieur