aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-22 14:01:05 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:28 +0000
commit7b7b0563e2167a4af30502db1b62b3dd8a12907c (patch)
treecfd58cf3bfd70ced722c8050580e11dc3d05dac7 /gnu/packages
parent06cb215d9d2d2c81b4bfa3f0cf34d925ef2fa6e3 (diff)
downloadguix-7b7b0563e2167a4af30502db1b62b3dd8a12907c.tar.gz
guix-7b7b0563e2167a4af30502db1b62b3dd8a12907c.zip
gnu: python-pytest-remotedata: Fix tests.
* gnu/packages/python-check.scm (python-pytest-remotedata): Fix tests. [arguments]<test-flags>: Ignore one more test, enable parallel tests. [native-inputs]: Add python-pytest-xdist. Change-Id: Ib5f58f415491ea4f5090af8bf47d31584edb037b
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-check.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1b80e402fd..6b577175f7 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1012,12 +1012,18 @@ were inadvertently left open at the end of a unit test.")
(build-system pyproject-build-system)
(arguments
(list
- #:test-flags #~(list "-k" (string-append
- "not test_default_behavior"
- " and not test_strict_behavior"
- " and not test_strict_with_decorator"))))
+ #:test-flags
+ #~(list "--numprocesses" (number->string (parallel-job-count))
+ "-k" (string-join
+ ;; Network access is required.
+ (list "not test_internet_access"
+ ;; Failed with assertion error.
+ "test_default_behavior"
+ "test_strict_with_decorator")
+ " and not "))))
(native-inputs
(list python-pytest
+ python-pytest-xdist
python-setuptools
python-setuptools-scm
python-wheel))