aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2024-09-10 03:27:16 +0200
committerLudovic Courtès <ludo@gnu.org>2024-12-16 00:21:05 +0100
commit79f8769530cc78297b2443856984b2b1338caa3c (patch)
tree043fe55ccebffcd5c75f2b239f8b52c44d54f344 /gnu/packages
parent1c35fe0831828f969644628418267442fd58e62c (diff)
downloadguix-79f8769530cc78297b2443856984b2b1338caa3c.tar.gz
guix-79f8769530cc78297b2443856984b2b1338caa3c.zip
gnu: cgit: Remove input labels.
* gnu/packages/version-control.scm (cgit) [inputs]: Remove labels. [arguments]<phases>: Adjust. Change-Id: Iff479fa636f7a4c4fef5137ae22934d4e213223b Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/version-control.scm49
1 files changed, 25 insertions, 24 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 497d31cf73..c077f0694d 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1373,7 +1373,7 @@ collaboration using typical untrusted file hosts or services.")
(lambda* (#:key inputs #:allow-other-keys)
;; Unpack the source of git into the 'git' directory.
(invoke "tar" "--strip-components=1" "-C" "git" "-xf"
- (assoc-ref inputs "git-source"))))
+ #$(this-package-input "git-source.tar.xz"))))
(add-after 'unpack 'patch-absolute-file-names
(lambda* (#:key inputs outputs #:allow-other-keys)
(define (quoted-file-name input path)
@@ -1428,29 +1428,30 @@ collaboration using typical untrusted file hosts or services.")
;; For building manpage.
(list asciidoc))
(inputs
- `( ;; Building cgit requires a Git source tree.
- ("git-source"
- ,(origin
- (method url-fetch)
- ;; cgit is tightly bound to git. Use GIT_VER from the Makefile,
- ;; which may not match the current (package-version git).
- (uri "mirror://kernel.org/software/scm/git/git-2.46.2.tar.xz")
- (sha256
- (base32 "18rcmvximgyg3v1a9papi9djfamiak0ys5cmgx7ll29nhp3a3s2y"))))
- ("bash-minimal" ,bash-minimal)
- ("openssl" ,openssl)
- ("python" ,python)
- ("python-docutils" ,python-docutils)
- ("python-markdown" ,python-markdown)
- ("python-pygments" ,python-pygments)
- ("zlib" ,zlib)
- ;; bzip2, groff, gzip and xz are inputs (not native inputs)
- ;; since they are actually substituted into cgit source and
- ;; referenced by the built package output.
- ("bzip2" ,bzip2)
- ("groff" ,groff)
- ("gzip" ,gzip)
- ("xz" ,xz)))
+ (list (origin
+ (method url-fetch)
+ ;; Building cgit requires a Git source tree.
+ ;; cgit is tightly bound to git. Use GIT_VER from the Makefile,
+ ;; which may not match the current (package-version git).
+ (uri "mirror://kernel.org/software/scm/git/git-2.46.2.tar.xz")
+ (sha256
+ (base32
+ "18rcmvximgyg3v1a9papi9djfamiak0ys5cmgx7ll29nhp3a3s2y"))
+ (file-name "git-source.tar.xz"))
+ bash-minimal
+ openssl
+ python
+ python-docutils
+ python-markdown
+ python-pygments
+ zlib
+ ;; bzip2, groff, gzip and xz are inputs (not native inputs)
+ ;; since they are actually substituted into cgit source and
+ ;; referenced by the built package output.
+ bzip2
+ groff
+ gzip
+ xz))
(home-page "https://git.zx2c4.com/cgit/")
(synopsis "Web frontend for git repositories")
(description