aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:21 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:20 +0200
commit766ee5803e2727cd2dcda0225030a35a2a116661 (patch)
tree0f5f71b0ea1d56cb2423949148d7c41921e8c80d /gnu/packages
parent6399cf4240f7b009e6fc24773c5f8bd7d7b83621 (diff)
downloadguix-766ee5803e2727cd2dcda0225030a35a2a116661.tar.gz
guix-766ee5803e2727cd2dcda0225030a35a2a116661.zip
gnu: Add ghc-brick-skylighting.
* gnu/packages/haskell-xyz.scm (ghc-brick-skylighting): New variable. Change-Id: I634c108edff99b1003c26dbb2f9107ed464a5e84
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 960136e872..290ea50ed6 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15905,6 +15905,26 @@ purposes. See the
an event handler and a drawing function and the library does the rest.")
(license license:bsd-3)))
+(define-public ghc-brick-skylighting
+ (package
+ (name "ghc-brick-skylighting")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "brick-skylighting" version))
+ (sha256
+ (base32 "1nw2x9zn0jlvykm89v80fh4187bxgn8l4cljgnf4mp4ci7aqjmkr"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "brick-skylighting")))
+ (inputs (list ghc-brick ghc-vty-6 ghc-skylighting-core))
+ (home-page "https://github.com/jtdaugherty/brick-skylighting/")
+ (synopsis "Show syntax-highlighted text in your Brick UI")
+ (description
+ "This package provides a module to use Skylighting to perform syntax
+highlighting and display the results in Brick-based interfaces.")
+ (license license:bsd-3)))
+
(define-public ghc-githash
(package
(name "ghc-githash")