aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-12-01 09:34:54 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-12-01 10:53:49 -0500
commit748ec628826cea3faa3679074d87fae9bc810080 (patch)
tree39366a2b057806f04c28289f40e954580042f7ad /gnu/packages
parentad9d0f8e58414749d52c2eb2c6998a0926b74388 (diff)
downloadguix-748ec628826cea3faa3679074d87fae9bc810080.tar.gz
guix-748ec628826cea3faa3679074d87fae9bc810080.zip
gnu: linux-libre: Move info manual to doc output.
The kernel Linux is installed in the system profile, which means the manual was not easily discoverable. Move it to the "doc" output, so that users can install the Linux documentation explicitly in their user profile without pulling the whole Linux package. * gnu/packages/linux.scm (make-linux-libre*) [outputs]: Conditionally add a "doc" output. [phases] {install-doc}: Install the info manual to the doc output, an create a "linux" symlink to it for convenience. * guix/build-system/linux-module.scm (make-linux-module-builder): Delete the "doc" output, if present.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5dde319361..6d2aa89d35 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -816,6 +816,7 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(version version)
(source source)
(supported-systems supported-systems)
+ (outputs `("out" ,@(if build-doc? '("doc") '())))
(build-system gnu-build-system)
(arguments
(list
@@ -842,10 +843,16 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(invoke "make" "infodocs")))
(add-after 'build-doc 'install-doc
(lambda _
- (with-directory-excursion "Documentation/output"
- (invoke "make" "-C" "texinfo" "install-info"
- (string-append "infodir=" #$output
- "/share/info"))))))
+ (let* ((info-dir (string-append #$output:doc
+ "/share/info"))
+ (info (string-append
+ info-dir "/TheLinuxKernel.info.gz")))
+ (with-directory-excursion "Documentation/output"
+ (invoke "make" "-C" "texinfo" "install-info"
+ (string-append "infodir=" info-dir)))
+ ;; Create a symlink, for convenience.
+ (symlink info (string-append info-dir
+ "/linux.info.gz"))))))
#~())
(add-before 'configure 'set-environment
(lambda* (#:key target #:allow-other-keys)