aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-06-10 16:53:48 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-06-10 16:53:48 -0400
commit6fe9a004dba2d4ddf69ff6f1714af15ffaa7e62a (patch)
tree0722760d8b72b270a9879151db7421f03b8e6456 /gnu/packages
parent767edbb6fe781d19c19971f2ccd3b0da8fd053fc (diff)
downloadguix-6fe9a004dba2d4ddf69ff6f1714af15ffaa7e62a.tar.gz
guix-6fe9a004dba2d4ddf69ff6f1714af15ffaa7e62a.zip
gnu: cqfd: Update to 5.4.0.
* gnu/packages/docker.scm (cqfd): Update to 5.4.0. [arguments]: Use gexps. Add #:make-flags. Remove install phase override.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/docker.scm29
1 files changed, 11 insertions, 18 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 3445453093..0b2a18d661 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019, 2020, 2021, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2020 Jesse Dowell <jessedowell@gmail.com>
@@ -664,7 +664,7 @@ provisioning etc.")
(define-public cqfd
(package
(name "cqfd")
- (version "5.3.0")
+ (version "5.4.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -673,25 +673,18 @@ provisioning etc.")
(file-name (git-file-name name version))
(sha256
(base32
- "0gy4kjy6v52acfk6ffbg5sp02k6176khhkms7zlwmywq8591bpww"))))
+ "1kilrh4ahza19lka9218s2wkfcbk5r2cq9adczhlnlfggdrqnglg"))))
(build-system gnu-build-system)
(arguments
;; The test suite requires a docker daemon and connectivity.
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; Fix the directory of the bash completion.
- (substitute* "Makefile"
- (("completionsdir=.*$")
- (string-append "completionsdir=" out
- "/etc/bash_completion.d; \\\n")))
- (invoke "make" "install"
- (string-append "PREFIX=" out))))))))
+ (list
+ #:tests? #f
+ #:make-flags #~(list (string-append "COMPLETIONSDIR="
+ #$output "/etc/bash_completion.d")
+ (string-append "PREFIX=" #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build))))
(home-page "https://github.com/savoirfairelinux/cqfd")
(synopsis "Convenience wrapper for Docker")
(description "cqfd is a Bash script that provides a quick and convenient