aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-09-14 18:07:37 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-09-14 21:39:12 +0200
commit6e0ab26f31cd2bb7e5d88719d3d458df68c1963e (patch)
treedce166713a1a0b5b06c44c2199c10105adb0cbd1 /gnu/packages
parentf4d920b9f7ac404b245693fe21b39b7c41a49a61 (diff)
downloadguix-6e0ab26f31cd2bb7e5d88719d3d458df68c1963e.tar.gz
guix-6e0ab26f31cd2bb7e5d88719d3d458df68c1963e.zip
gnu: r-preprocesscore: Move to (gnu packages bioconductor).
* gnu/packages/statistics.scm (r-preprocesscore): Move from here... * gnu/packages/bioconductor.scm (r-preprocesscore): ...to here. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm21
-rw-r--r--gnu/packages/statistics.scm21
2 files changed, 21 insertions, 21 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 5505747f67..1f4ae8170f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8287,3 +8287,24 @@ a Python script to demultiplex libraries and trim off primer sequences. With
a standard alignment software the required bam files can be then be
generated.")
(license license:gpl3+)))
+
+(define-public r-preprocesscore
+ (package
+ (name "r-preprocesscore")
+ (version "1.50.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "preprocessCore" version))
+ (sha256
+ (base32
+ "0q1406kswylc8zn5k3wyd34p34pfzbhi1ggkfsh30zcjp6adbwjl"))))
+ (properties
+ `((upstream-name . "preprocessCore")))
+ (build-system r-build-system)
+ (home-page "https://github.com/bmbolstad/preprocessCore")
+ (synopsis "Collection of pre-processing functions")
+ (description
+ "This package provides a library of core pre-processing and normalization
+routines.")
+ (license license:lgpl2.0+)))
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 82f97c679e..03a63e6ba1 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4079,27 +4079,6 @@ framework, with additional code inspection and report generation tools.")
hierarchical clustering dendrograms.")
(license license:gpl2+)))
-(define-public r-preprocesscore
- (package
- (name "r-preprocesscore")
- (version "1.50.0")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "preprocessCore" version))
- (sha256
- (base32
- "0q1406kswylc8zn5k3wyd34p34pfzbhi1ggkfsh30zcjp6adbwjl"))))
- (properties
- `((upstream-name . "preprocessCore")))
- (build-system r-build-system)
- (home-page "https://github.com/bmbolstad/preprocessCore")
- (synopsis "Collection of pre-processing functions")
- (description
- "This package provides a library of core pre-processing and normalization
-routines.")
- (license license:lgpl2.0+)))
-
(define-public r-fastcluster
(package
(name "r-fastcluster")