aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-07 17:19:12 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:39 +0000
commit6ccd3b28e4ba3f3f4ff921d19714f4240a3b85a6 (patch)
tree32968acb58bf7e4f1e80fd156fe1f530f32991a0 /gnu/packages
parent8348b7c8e949d51e0a4b57135f37d87ccf30214b (diff)
downloadguix-6ccd3b28e4ba3f3f4ff921d19714f4240a3b85a6.tar.gz
guix-6ccd3b28e4ba3f3f4ff921d19714f4240a3b85a6.zip
gnu: python-websocket-client: Update to 1.8.0.
* gnu/packages/python-web.scm (python-websocket-client): Update to 1.8.0. [build-system]: Use pyproject-build-system. [arguments]: Remove 'skip-network-test and custom 'check phase; use #:test-flags to disable test. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Ib5794c64df1d9c3759c3f9a8c1d0f8642afa83c4
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm29
1 files changed, 13 insertions, 16 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1a3a0840ad..f7e5103b9b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3564,28 +3564,25 @@ sanitizer Rust crate.")
(define-public python-websocket-client
(package
(name "python-websocket-client")
- (version "1.2.3")
+ (version "1.8.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "websocket-client" version))
+ (uri (pypi-uri "websocket_client" version))
(sha256
- (base32 "1xba9z6b211pandrlk2l5p8wj6gn7yfkpq1sxfbqjl6c19n8258k"))))
- (build-system python-build-system)
+ (base32 "1nn3qi5g59j55wfy2z02j6lq2cm281fq0wi406b2yqys8jgxyf9j"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-network-test
- (lambda _
- ;; This test requires networking.
- (substitute* "websocket/tests/test_http.py"
- (("def testConnect") "def _testConnect"))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "websocket/tests")))))))
+ (list
+ #:test-flags
+ ;; This test requires networking.
+ '(list "-k" "not testConnect")))
(native-inputs
- (list python-pysocks python-pytest python-websockets))
+ (list python-pysocks
+ python-pytest
+ python-setuptools
+ python-websockets
+ python-wheel))
(home-page "https://github.com/websocket-client/websocket-client")
(synopsis "WebSocket client for Python")
(description "The Websocket-client module provides the low level APIs for