aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-12 13:44:06 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:49 +0100
commit6be3cbad1351ff9d3ecd56e7f2372e9c54d4af7c (patch)
tree02322540add0a8b6e41bb5e4a88b12af100435eb /gnu/packages
parent8aa11899bdb2e09191623c961ac65891935e3598 (diff)
downloadguix-6be3cbad1351ff9d3ecd56e7f2372e9c54d4af7c.tar.gz
guix-6be3cbad1351ff9d3ecd56e7f2372e9c54d4af7c.zip
gnu: go-golang-org-x-net: Enable tests.
* gnu/packages/golang-build.scm (go-golang-org-x-net): Enable tests. [arguments]: <#:phases>: Use custom 'check phase. [propagated-inputs]: Add go-golang-org-x-crypto. Change-Id: I632cdc7541bde898214aa006434fa96a5050fa62
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-build.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index df5fa638d3..200170d9c4 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -307,14 +307,21 @@ loading algorithms.")
(arguments
(list
#:import-path "golang.org/x/net"
- ;; Source-only package
- #:tests? #f
#:phases
#~(modify-phases %standard-phases
- ;; Source-only package
- (delete 'build))))
+ ;; XXX: Workaround for go-build-system's lack of Go modules
+ ;; support.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
(propagated-inputs
- (list go-golang-org-x-sys go-golang-org-x-term go-golang-org-x-text))
+ (list go-golang-org-x-crypto
+ go-golang-org-x-sys
+ go-golang-org-x-term
+ go-golang-org-x-text))
(home-page "https://go.googlesource.com/net")
(synopsis "Go supplemental networking libraries")
(description
lexedBuildOutput'. (Settings::update): Likewise. * nix/libstore/globals.hh (Settings)[multiplexedBuildOutput]: New field. Update 'printBuildTrace' documentation. * nix/libstore/worker-protocol.hh (PROTOCOL_VERSION): Bump to 0.163. * nix/nix-daemon/nix-daemon.cc (performOp) <wopSetOptions>: Special-case "multiplexed-build-output" and remove "use-ssh-substituter". * guix/store.scm (set-build-options): Add #:multiplexed-build-output? and honor it. (%protocol-version): Bump to #x163. * tests/store.scm ("multiplexed-build-output"): New test. fixlet Ludovic Courtès 2018-10-02daemon: Remove unused 'Settings' fields....* nix/libstore/globals.hh (Settings)[sshSubstituterHosts] [useSshSubstituter, logServers, enableImportNative]: Remove fields. * nix/libstore/globals.cc (Settings::Settings, Settings::update): Remove references to these. Ludovic Courtès 2018-03-30daemon: Remove dead code....* nix/libstore/globals.cc (Settings::loadConfFile, Settings::unpack): Remove. * nix/libstore/globals.hh: Adjust accordingly. * nix/libstore/misc.cc (queryMissing): Remove. * nix/libstore/misc.hh: Adjust accordingly. * nix/libstore/store-api.cc (followLinksToStore) (followLinksToStorePath, computeStorePathForHash): Remove. * nix/libstore/store-api.hh: Adjust accordingly. Ludovic Courtès 2018-01-07daemon: Make libbz2 an optional dependency....* config-daemon.ac: Don't bail out when libbz2 is missing. Define 'HAVE_LIBBZ2' Automake conditional. * nix/libstore/build.cc: Wrap relevant bits in '#if HAVE_BZLIB_H'. * nix/libstore/globals.cc (Settings::Settings): 'logCompression' defaults to COMPRESSION_GZIP when HAVE_BZLIB_H is false. * nix/libstore/globals.hh (CompressionType): Make 'COMPRESSION_BZIP2' conditional on HAVE_BZLIB_H. * nix/local.mk (guix_register_LDADD, guix_daemon_LDADD): Add -lbz2 only when HAVE_LIBBZ2. * nix/nix-daemon/guix-daemon.cc (parse_opt): Ignore "bzip2" when not HAVE_BZLIB_H. Ludovic Courtès 2018-01-07daemon: Add gzip log compression....* nix/nix-daemon/guix-daemon.cc (GUIX_OPT_LOG_COMPRESSION): New macro. (options): Mark "disable-log-compression" as hidden and add "log-compression". (parse_opt): Handle GUIX_OPT_LOG_COMPRESSION. * nix/libstore/build.cc (DerivationGoal): Add 'gzLogFile'. (openLogFile): Initialize it when 'logCompression' is COMPRESSION_GZIP. (closeLogFile, handleChildOutput): Honor 'gzLogFile'. * nix/libstore/globals.hh (Settings)[compressLog]: Remove. [logCompression]: New field. (CompressionType): New enum. * nix/libstore/globals.cc (Settings::Settings): Initialize it. (update): Remove '_get' call for 'compressLog'. * nix/local.mk (guix_daemon_LDADD, guix_register_LDADD): Add -lz. * guix/store.scm (log-file): Handle '.gz' log files. * tests/guix-daemon.sh: Add test with '--log-compression=gzip'. * doc/guix.texi (Invoking guix-daemon): Adjust accordingly. * config-daemon.ac: Check for libz and zlib.h. Ludovic Courtès