aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZongyuan Li <zongyuan.li@c0x0o.me>2024-12-23 10:39:54 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-23 11:02:42 +0100
commit66f64e0ee81143f8273ecd5a99e8303034278b5d (patch)
treeff0af9590eb8d9889f6bb6e210c65272949ca937 /gnu/packages
parent52f5c0fa89e2148c62a6092d433a10323c8e7681 (diff)
downloadguix-66f64e0ee81143f8273ecd5a99e8303034278b5d.tar.gz
guix-66f64e0ee81143f8273ecd5a99e8303034278b5d.zip
gnu: podman: Add "docker" output.
* gnu/packages/containers.scm (podman)[arguments]<#:phases>[install-docker]: New phase. Change-Id: I1abaa6412180185808a5c286ec5d2f7e117dcbc7 Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/containers.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index d43536c025..d1d389c9fc 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -46,6 +46,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages glib)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
#:use-module (gnu packages guile)
@@ -468,6 +469,9 @@ Its main purpose is to support the key usage by @code{docker-init}:
(package
(name "podman")
(version "5.3.1")
+ (outputs '("out" "docker"))
+ (properties
+ `((output-synopsis "docker" "docker alias for podman")))
(source
(origin
(method git-fetch)
@@ -540,6 +544,19 @@ Its main purpose is to support the key usage by @code{docker-init}:
,(string-append #$passt "/bin")
,(string-append #$procps "/bin") ; ps
"/run/privileged/bin")))))
+ (add-after 'install 'install-docker
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((docker (assoc-ref outputs "docker")))
+ ;; So it picks podman of the other output.
+ (let ((bin-dir (string-append (assoc-ref outputs "out")
+ "/bin")))
+ (substitute* "docker/docker.in"
+ (("[$][{]BINDIR[}]") bin-dir)
+ (("[$][{]ETCDIR[}]") "/etc")))
+ (invoke "make" "install.docker"
+ (string-append "PREFIX=" (assoc-ref outputs "docker"))
+ (string-append "ETCDIR=" (string-append (assoc-ref outputs "docker")
+ "/etc"))))))
(add-after 'install 'install-completions
(lambda _
(invoke "make" "install.completions"
@@ -558,6 +575,7 @@ Its main purpose is to support the key usage by @code{docker-init}:
git-minimal/pinned
go-1.22
go-github-com-go-md2man
+ gnu-gettext ; for envsubst
mandoc
pkg-config
python))