aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2024-08-17 11:54:31 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:46 +0100
commit66abf5f2f05c1b1b7f30fe0239292b01a411c2e6 (patch)
tree4897c9e3efe239f3cd004ed94723460af82988e3 /gnu/packages
parent420a8a5096cda06f2dc2ae7397d08957d5759a55 (diff)
downloadguix-66abf5f2f05c1b1b7f30fe0239292b01a411c2e6.tar.gz
guix-66abf5f2f05c1b1b7f30fe0239292b01a411c2e6.zip
gnu: Add go-github-com-mailru-easyjson.
* gnu/packages/golang-web.scm (go-github-com-mailru-easyjson): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I62da25345aa44a0d6811ea0e50de58eeaea0fbe4
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 28eba7f5d2..240b622e35 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2022 Adam Kandur <kefironpremise@gmail.com>
;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2022 Leo Nikkilä <hello@lnikki.la>
;;; Copyright © 2022 jgart via Guix-patches via <guix-patches@gnu.org>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
@@ -2266,6 +2267,34 @@ router.")
gopacket/routing.Router} interface for Golang.")
(license license:bsd-3)))
+(define-public go-github-com-mailru-easyjson
+ (package
+ (name "go-github-com-mailru-easyjson")
+ (version "0.7.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mailru/easyjson")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0clifkvvy8f45rv3cdyv58dglzagyvfcqb63wl6rij30c5j2pzc1"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mailru/easyjson"))
+ (propagated-inputs
+ (list go-github-com-josharian-intern))
+ (home-page "https://github.com/mailru/easyjson")
+ (synopsis "JSON serializer for Golang")
+ (description
+ "Package @code{easyjson} implements functionality to marshal/unmarshal
+Golang structs to/from JSON without the use of reflection. It also aims to
+keep generated Go code simple enough so that it can be easily optimized or
+fixed.")
+ (license license:expat)))
+
(define-public go-github-com-makeworld-the-better-one-go-gemini
(package
(name "go-github-com-makeworld-the-better-one-go-gemini")