aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-27 09:24:18 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-27 09:39:18 +0900
commit64e1ae00e7e12cb07fe29efab631c6143acbe002 (patch)
tree24816cb811de0047e6c332f142018b0e346c3706 /gnu/packages
parentce6f571fbe9f9426ebcc11c84c2a413aa22b877c (diff)
downloadguix-64e1ae00e7e12cb07fe29efab631c6143acbe002.tar.gz
guix-64e1ae00e7e12cb07fe29efab631c6143acbe002.zip
gnu: Add xdg-desktop-portal-next.
This is based on Dan's "xdg-desktop-portal: Update to 1.18.4." commit, now reverted. * gnu/packages/freedesktop.scm (xdg-desktop-portal-next): New variable. * gnu/packages/patches/xdg-desktop-portal-disable-portal-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I7360d915bb0450f6772232c126fd0d4a4fec8997
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/freedesktop.scm35
-rw-r--r--gnu/packages/patches/xdg-desktop-portal-disable-portal-tests.patch56
2 files changed, 90 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 2a78895a20..23ed788689 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -27,7 +27,7 @@
;;; Copyright © 2021 Robby Zambito <contact@robbyzambito.me>
;;; Copyright © 2021, 2022, 2023 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021, 2022 John Kehayias <john.kehayias@protonmail.com>
-;;; Copyright © 2021, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021-2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
@@ -39,6 +39,7 @@
;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
;;; Copyright © 2024 Dariqq <dariqq@posteo.net>
;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
+;;; Copyright © 2024 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -136,6 +137,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages video)
+ #:use-module (gnu packages virtualization)
#:use-module (gnu packages w3m)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
@@ -3071,6 +3073,37 @@ The portal interfaces include APIs for file access, opening URIs, printing
and others.")
(license license:lgpl2.1+)))
+(define-public xdg-desktop-portal-next
+ (package
+ (inherit xdg-desktop-portal)
+ (version "1.18.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/flatpak/xdg-desktop-portal/releases/download/"
+ version "/xdg-desktop-portal-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0r8y8qmzcfj7b7brqcxr9lg8pavfds815ffvj0kqc378fhgaln5q"))
+ ;; Disable portal tests since they try to use fuse.
+ (patches (search-patches "xdg-desktop-portal-disable-portal-tests.patch"))))
+ (build-system meson-build-system)
+ (arguments
+ (substitute-keyword-arguments (package-arguments xdg-desktop-portal)
+ ((#:configure-flags _ ''())
+ #~(list "-Dsystemd=disabled"))))
+ (native-inputs
+ (list pkg-config
+ `(,glib "bin")
+ gettext-minimal
+ python
+ python-dbusmock
+ python-pytest
+ python-pytest-xdist))
+ (inputs (modify-inputs (package-inputs xdg-desktop-portal)
+ (prepend bubblewrap)))))
+
(define-public xdg-desktop-portal-gtk
(package
(name "xdg-desktop-portal-gtk")
diff --git a/gnu/packages/patches/xdg-desktop-portal-disable-portal-tests.patch b/gnu/packages/patches/xdg-desktop-portal-disable-portal-tests.patch
new file mode 100644
index 0000000000..5e13493613
--- /dev/null
+++ b/gnu/packages/patches/xdg-desktop-portal-disable-portal-tests.patch
@@ -0,0 +1,56 @@
+From b7750fa99c31c5f28ac2053fa154bef4038b5cc0 Mon Sep 17 00:00:00 2001
+From: dan <i@dan.games>
+Date: Tue, 2 Jul 2024 19:37:38 +0800
+Subject: [PATCH] tests: remove portal tests.
+
+---
+ tests/meson.build | 24 ------------------------
+ 1 file changed, 24 deletions(-)
+
+diff --git a/tests/meson.build b/tests/meson.build
+index a2dafee..bcd87be 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -181,18 +181,6 @@ portal_tests = [
+
+ test_env = env_tests
+ test_env.set('XDG_CURRENT_DESKTOP', 'test')
+-foreach p : portal_tests
+- test(
+- 'test-portals-@0@'.format(p),
+- test_portals,
+- args: ['--verbose', '--keep-going', '--tap', '-p', '/portal/@0@'.format(p)],
+- depends: [test_backends, test_portals],
+- env: test_env,
+- is_parallel: false,
+- protocol: test_protocol,
+- suite: 'portals',
+- )
+-endforeach
+
+ # Split the portal tests into one test per portal, this makes debugging a lot
+ # easier.
+@@ -204,18 +192,6 @@ portal_limited = [
+
+ limited_env = env_tests
+ limited_env.set('XDG_CURRENT_DESKTOP', 'limited')
+-foreach p : portal_limited
+- test(
+- 'limited-portals-@0@'.format(p),
+- limited_portals,
+- args: ['--verbose', '--keep-going', '--tap', '-p', '/limited/@0@'.format(p)],
+- depends: [test_backends, limited_portals],
+- env: limited_env,
+- is_parallel: false,
+- protocol: test_protocol,
+- suite: 'portals',
+- )
+-endforeach
+
+ if enable_installed_tests
+ install_data(
+
+base-commit: 11c8a96b147aeae70e3f770313f93b367d53fedd
+--
+2.41.0
+