aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-11-16 08:26:42 +0100
committerLudovic Courtès <ludo@gnu.org>2017-11-17 10:59:21 +0100
commit64a4d394039b84a3e2dfe2ec253ae81ad87c9c89 (patch)
tree0f43edf93f0e064f7add80346df7d02e46285cc9 /gnu/packages
parent284d7da3bbc246b289c47be0d78db0269b0b4a01 (diff)
downloadguix-64a4d394039b84a3e2dfe2ec253ae81ad87c9c89.tar.gz
guix-64a4d394039b84a3e2dfe2ec253ae81ad87c9c89.zip
gnu: nftables: Update to 0.8.
* gnu/packages/linux.scm (nftables): Update to 0.8. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 90f28ca0e7..f526232b37 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4145,7 +4145,7 @@ used by nftables.")
(define-public nftables
(package
(name "nftables")
- (version "0.7")
+ (version "0.8")
(source
(origin
(method url-fetch)
@@ -4153,7 +4153,7 @@ used by nftables.")
"/files/nftables-" version ".tar.bz2"))
(sha256
(base32
- "0hzdqigdx4i6jbpxbdyq4zy4p4waqn8l6vvz7685ikh1v0wr4qzy"))))
+ "16iq9x0qxikdhp1nan500rk33ycqddl1k57876m4dfv3n7kqhnrz"))))
(build-system gnu-build-system)
(inputs `(("bison", bison)
("flex", flex)
ltip'>* gnu/installer/services.scm (<system-service>)[snippet]: Change to be a list of sexps and add default value. [packages]: New field. (%system-services): Adjust 'snippet' fields to be lists of sexps. Add Openbox, awesome, i3, and ratpoison. (system-services->configuration): Adjust 'snippet' handling. Honor 'packages' field. Ludovic Courtès 2019-04-14installer: Fix snippet for the DHCP client....* gnu/installer/services.scm (%system-services): Fix typo in DHCP client snippet. Ludovic Courtès 2019-04-14installer: Add wpa-supplicant along with NetworkManager and Connman....* gnu/installer/services.scm (%system-services) <network-manager, connman>: Add a 'wpa-supplicant-service-type' instance. (system-services->configuration): Unsplice it. Ludovic Courtès 2019-04-08installer: Use 'append' and 'list' instead of 'cons*'....* gnu/installer/services.scm (system-services->configuration): Use 'append' and 'list' instead of 'cons*'. Ludovic Courtès 2019-04-08installer: Generate 'set-xorg-configuration' snippet....* gnu/installer/services.scm (system-services->configuration): Add 'set-xorg-configuration' service. * gnu/installer/steps.scm (format-configuration): Add 'xorg' service module. Ludovic Courtès 2019-04-08installer: Xfce service uses the 'service' form....* gnu/installer/services.scm (%system-services): Adjust Xfce snippet to use the 'service' form. Ludovic Courtès 2019-04-07installer: Internationalize service "names"....* gnu/installer/services.scm (%system-services): Mark networking service names with 'G_'. * gnu/installer/newt/services.scm (run-networking-cbt-page): Pass 'system-service-name' through 'G_'. Ludovic Courtès 2019-04-07installer: Offer NM, Connman, and DHCP to non-desktop installs....* gnu/installer/services.scm (%system-services): Add NetworkManager, Connman, and the DHCP client. * gnu/installer/newt/services.scm (run-networking-cbt-page): Add 'network-management?' parameter and honor it. (run-services-page): Adjust call accordingly. Ludovic Courtès 2019-04-07installer: Add dialog to select networking services....* gnu/installer/newt/services.scm (run-networking-cbt-page): New procedure. (run-services-page): Call it. * gnu/installer/services.scm (%system-services): Add OpenSSH and Tor. (networking-system-service?): New procedure. * gnu/installer/steps.scm (format-configuration): Add 'networking' and 'ssh' to the service modules. Ludovic Courtès 2019-04-07installer: Generalize desktop environments to system services....* gnu/installer/services.scm (<desktop-environment>): Rename to... (<system-service>): ... this. Add a 'type' field. (%desktop-environments): Rename to... (%system-services): ... this. (desktop-system-service?): New procedure. (desktop-environments->configuration): Rename to... (system-services->configuration): ... this. Determine the base list of services based on whether SERVICES contains at least one "desktop" service. * gnu/installer/newt/services.scm (run-desktop-environments-cbt-page): Adjust accordingly. * gnu/installer.scm (installer-steps): Likewise. Ludovic Courtès 2019-03-27services: Deprecate 'xfce-desktop-service'....* gnu/services/desktop.scm (xfce-desktop-service-type)[default-value] [description]: New fields. (xfce-desktop-service): Deprecate. * gnu/system/examples/desktop.tmpl: Use the (service …) form. * gnu/installer/services.scm (%desktop-environments): Add TODO comment. * doc/guix.texi (Desktop Services): Adjust accordingly, and fix spelling of "Xfce" throughout. Ludovic Courtès 2019-03-27services: Deprecate 'gnome-desktop-service'....* gnu/services/desktop.scm (gnome-desktop-service-type)[default-value]: New field. (gnome-desktop-service): Deprecate. * gnu/installer/services.scm (%desktop-environments): Use the (service …) form for GNOME. * gnu/system/examples/desktop.tmpl: Likewise. * doc/guix.texi (Desktop Services): Adjust accordingly. Ludovic Courtès 2019-03-27installer: Use the (service …) form for MATE....* gnu/installer/services.scm (%desktop-environments): Use 'mate-desktop-service-type' for MATE. Ludovic Courtès 2019-01-17installer: Add services page....Add a page to select services, for now only desktop environments choice is available. * gnu/installer.scm (steps): Add services step. * gnu/installer/newt.scm (newt-installer): Add services-page field. * gnu/installer/newt/services.scm: New file. * gnu/installer/record.scm (installer): Add services-page field. * gnu/installer/services.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add new files. * po/guix/POTFILES.in: Add new files. Mathieu Othacehe