aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-10 10:24:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-12-10 10:24:45 +0200
commit63e06f30ce20fa846a7e2e814976fefcd9eda7d3 (patch)
treed5bf2f4d64ea7e1dd2f6db7e1456611c2472a08a /gnu/packages
parent9c30fb27a42bf10a733ef5165df7869588f0b27c (diff)
downloadguix-63e06f30ce20fa846a7e2e814976fefcd9eda7d3.tar.gz
guix-63e06f30ce20fa846a7e2e814976fefcd9eda7d3.zip
gnu: ubuntu-keyring: Update to 2023.11.28.1.
* gnu/packages/debian.scm (ubuntu-keyring): Update to 2023.11.28.1. [native-inputs]: Remove gzip; add xz. Change-Id: Id90acc7a58085321ac96b6ab520f54b20911a8c1
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/debian.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index 728f2cc845..b0a0b9e5d3 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -149,15 +149,15 @@ contains the archive keys used for that.")
(define-public ubuntu-keyring
(package
(name "ubuntu-keyring")
- (version "2021.03.26")
+ (version "2023.11.28.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://launchpad.net/ubuntu/+archive/primary/"
- "+files/" name "_" version ".tar.gz"))
+ "+files/" name "_" version ".tar.xz"))
(sha256
(base32
- "1ccvwh4s51viyhcg8gh189jmvbrhc5wv1bbp4minz3200rffsbj9"))))
+ "0bmafky67hrb79baaydmw7al21lz0wgi4ks5dqfkfqamw5d4bkdf"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
@@ -167,7 +167,7 @@ contains the archive keys used for that.")
(apt (string-append out "/etc/apt/trusted.gpg.d/"))
(key (string-append out "/share/keyrings/")))
(setenv "PATH" (string-append
- (assoc-ref %build-inputs "gzip") "/bin:"
+ (assoc-ref %build-inputs "xz") "/bin:"
(assoc-ref %build-inputs "tar") "/bin"))
(invoke "tar" "xvf" (assoc-ref %build-inputs "source"))
(for-each (lambda (file)
@@ -175,10 +175,9 @@ contains the archive keys used for that.")
(find-files "." "ubuntu-[^am].*\\.gpg$"))
(for-each (lambda (file)
(install-file file key))
- (find-files "." "ubuntu-[am].*\\.gpg$")))
- #t)))
+ (find-files "." "ubuntu-[am].*\\.gpg$"))))))
(native-inputs
- (list tar gzip))
+ (list tar xz))
(home-page "https://launchpad.net/ubuntu/+source/ubuntu-keyring")
(synopsis "GnuPG keys of the Ubuntu archive")
(description
ot;0.0.0" revision commit)) (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/3ximus/abstractdark-sddm-theme") (commit commit))) (file-name (git-file-name name version)) (sha256 (base32 "1si141hnp4lr43q36mbl3anlx0a81r8nqlahz3n3l7zmrxb56s2y")))) (build-system copy-build-system) (arguments `(#:install-plan '(("." "/share/sddm/themes/abstractdark")))) (home-page "https://github.com/3ximus/abstractdark-sddm-theme") (synopsis "Abstract Dark theme for SDDM") (description "This package provides a minimalistic dark theme for SDDM, black background with abstract shapes. Inspired by solarized-sddm-theme.") (license license:gpl3+)))) (define-public dexy-color-sddm-theme (let ((commit "7929384dbb9305e6da53a8942bca3d75593fd99f") (revision "0")) (package (name "dexy-color-sddm-theme") (version (git-version "0.0.0" revision commit)) (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/L4ki/Dexy-Plasma-Themes") (commit commit))) (file-name (git-file-name name version)) (sha256 (base32 "1dcp3pvs6x63740sz852yr19fjrdnh81dbrq7rssgm6ssi1rqjig")))) (build-system copy-build-system) (arguments `(#:install-plan '(("Dexy-Color-SDDM" "/share/sddm/themes/dexy-color-sddm")))) (home-page "https://github.com/L4ki/Dexy-Plasma-Themes") (synopsis "Dexy Color theme for SDDM") (description "This package provides a minimalistic and modern SDDM theme with blured background.") (license license:gpl3+)))) (define-public guix-simplyblack-sddm-theme (package (name "guix-simplyblack-sddm-theme") (version "0.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/plattfot/guix-simplyblack-sddm") (commit version))) (file-name (git-file-name name version)) (sha256 (base32 "1fwny6b0xpjs8ad2b16pyxd27gf0sr0nillmhc2h5k0q7dva21vi")))) (build-system trivial-build-system) (arguments `(#:modules ((guix build utils)) #:builder (begin (use-modules (guix build utils)) (let* ((out (assoc-ref %outputs "out")) (sddm-themes (string-append out "/share/sddm/themes"))) (mkdir-p sddm-themes) (copy-recursively (assoc-ref %build-inputs "source") (string-append sddm-themes "/guix-simplyblack-sddm")))))) (home-page "https://github.com/plattfot/guix-simplyblack-sddm") (synopsis "Guix based theme for SDDM") (description "This package provides a simple theme for SDDM, black background with Guix's logo. Based on Arch linux's archlinux-simplyblack theme.") ;; Theme under cc-by-sa3.0, guix logo under license:cc-by-sa4.0 (license (list license:cc-by-sa3.0 license:cc-by-sa4.0)))) (define-public chili-sddm-theme (package (name "chili-sddm-theme") (version "0.1.5") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/MarianArlt/sddm-chili") (commit version))) (file-name (git-file-name name version)) (sha256 (base32 "036fxsa7m8ymmp3p40z671z163y6fcsa9a641lrxdrw225ssq5f3")))) (build-system trivial-build-system) (arguments `(#:modules ((guix build utils)) #:builder (begin (use-modules (guix build utils)) (let* ((out (assoc-ref %outputs "out")) (sddm-themes (string-append out "/share/sddm/themes"))) (mkdir-p sddm-themes) (copy-recursively (assoc-ref %build-inputs "source") (string-append sddm-themes "/chili")))))) (home-page "https://github.com/MarianArlt/sddm-chili") (synopsis "Chili theme for SDDM") (description "Chili reduces all the clutter and leaves you with a clean, easy to use, login interface with a modern yet classy touch.") (license license:gpl3+))) (define-public sugar-dark-sddm-theme (package (name "sugar-dark-sddm-theme") (version "1.2") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/MarianArlt/sddm-sugar-dark") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0gx0am7vq1ywaw2rm1p015x90b75ccqxnb1sz3wy8yjl27v82yhb")))) (build-system trivial-build-system) (arguments `(#:modules ((guix build utils)) #:builder (begin (use-modules (guix build utils)) (let* ((out (assoc-ref %outputs "out")) (sddm-themes (string-append out "/share/sddm/themes"))) (mkdir-p sddm-themes) (copy-recursively (assoc-ref %build-inputs "source") (string-append sddm-themes "/sugar-dark")))))) (home-page "https://github.com/MarianArlt/sddm-sugar-dark") (synopsis "Sugar dark theme for SDDM") (description "Sugar is extremely customizable and so sweet it will probably cause you diabetes just from looking at it. Sweeten the login experience for your users, your family and yourself") (license license:gpl3+))) (define-public sugar-light-sddm-theme (package (name "sugar-light-sddm-theme") (version "1.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/MarianArlt/sddm-sugar-light") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1sfd5bi5jcfz3hmvvr3smalywixa70g5j96qgx1220mp6rqf886k")))) (build-system trivial-build-system) (arguments `(#:modules ((guix build utils)) #:builder (begin (use-modules (guix build utils)) (let* ((out (assoc-ref %outputs "out")) (sddm-themes (string-append out "/share/sddm/themes"))) (mkdir-p sddm-themes) (copy-recursively (assoc-ref %build-inputs "source") (string-append sddm-themes "/sugar-light")))))) (home-page "https://github.com/MarianArlt/sddm-sugar-light") (synopsis "Sugar light theme for SDDM") (description "Sugar is extremely customizable and so sweet it will probably cause you diabetes just from looking at it. Sweeten the login experience for your users, your family and yourself") (license license:gpl3+))) (define-public lightdm (package (name "lightdm") (version "1.32.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/canonical/lightdm") (commit version))) (file-name (git-file-name name version)) (sha256 (base32 "1wr60c946p8jz9kb8zi4cd8d4mkcy7infbvlfzwajiglc22nblxn")) (patches (search-patches "lightdm-arguments-ordering.patch" "lightdm-vncserver-check.patch" "lightdm-vnc-color-depth.patch" "lightdm-vnc-ipv6.patch")))) (build-system gnu-build-system) (arguments (list #:parallel-tests? #f ; fails when run in parallel #:configure-flags #~(list "--localstatedir=/var" "--enable-gtk-doc" ;; Otherwise the test suite fails on such a warning. "CFLAGS=-Wno-error=missing-prototypes") #:phases #~(modify-phases %standard-phases (add-after 'unpack 'fix-paths (lambda* (#:key inputs #:allow-other-keys) (substitute* "src/shared-data-manager.c" (("/bin/rm") (search-input-file inputs "bin/rm"))) (substitute* '("data/users.conf" "common/user-list.c") (("/bin/false") (search-input-file inputs "bin/false")) (("/usr/sbin/nologin") (search-input-file inputs "sbin/nologin"))) (substitute* "src/seat.c" (("/bin/sh") (search-input-file inputs "bin/sh"))))) (add-before 'check 'pre-check (lambda _ (wrap-program "tests/src/test-python-greeter" #:sh (which "bash") `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH"))) `("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH")))) ;; Avoid printing locale warnings, which trip up the text ;; matching tests. (unsetenv "LC_ALL")))))) (inputs (list audit bash-minimal ;for cross-compilation coreutils-minimal ;ditto linux-pam shadow ;for sbin/nologin libgcrypt libxcb libxdmcp)) (native-inputs (list accountsservice autoconf automake gobject-introspection gtk-doc pkg-config itstool intltool libtool vala ;for Vala bindings ;; For tests ;; All tests fail with dbus >= 1.15.2, see ;; https://github.com/canonical/lightdm/issues/346 dbus-1.15.0 python-wrapper python-pygobject which yelp-tools)) ;; Required by liblightdm-gobject-1.pc. (propagated-inputs (list glib libx11 libxklavier)) (home-page "https://www.freedesktop.org/wiki/Software/LightDM/") (synopsis "Lightweight display manager") (description "The Light Display Manager (LightDM) is a cross-desktop display manager which supports different greeters.") (license license:gpl3+))) (define-public lightdm-gtk-greeter (package (name "lightdm-gtk-greeter") (version "2.0.8") (source (origin (method url-fetch) (uri (string-append "https://github.com/xubuntu/lightdm-gtk-greeter" "/releases/download/lightdm-gtk-greeter-" version "/" "lightdm-gtk-greeter-" version ".tar.gz")) (sha256 (base32 "04q62mvr97l9gv8h37hfarygqc7p0498ig7xclcg4kxkqw0b7yxy")))) (build-system glib-or-gtk-build-system) (arguments (list #:configure-flags #~(list "--disable-indicator-services-command" ;requires upstart ;; Put the binary under /bin rather than /sbin, so that it gets ;; wrapped by the glib-or-gtk-wrap phase. (string-append "--sbindir=" #$output "/bin") (string-append "--with-libxklavier") (string-append "--enable-at-spi-command=" (search-input-file %build-inputs "libexec/at-spi-bus-launcher") " --launch-immediately")) #:phases #~(modify-phases %standard-phases (add-after 'unpack 'customize-default-config-path (lambda _ (substitute* "src/Makefile.in" ;; Have the default config directory sourced from ;; /etc/lightdm/lightdm-gtk-greeter.conf, which is where the ;; lightdm service writes it. (("\\$\\(sysconfdir)/lightdm/lightdm-gtk-greeter.conf") "/etc/lightdm/lightdm-gtk-greeter.conf")))) (add-after 'install 'fix-.desktop-file (lambda* (#:key outputs #:allow-other-keys) (substitute* (search-input-file outputs "share/xgreeters/lightdm-gtk-greeter.desktop") (("Exec=lightdm-gtk-greeter") (string-append "Exec=" (search-input-file outputs "bin/lightdm-gtk-greeter")))))) (add-after 'glib-or-gtk-wrap 'custom-wrap (lambda* (#:key outputs #:allow-other-keys) (wrap-script (search-input-file outputs "bin/lightdm-gtk-greeter") ;; Wrap GDK_PIXBUF_MODULE_FILE, so that the SVG loader is ;; available at all times even outside of profiles, such as ;; when used in the lightdm-service-type. Otherwise, it ;; wouldn't be able to display its own icons. `("GDK_PIXBUF_MODULE_FILE" = (,(search-input-file outputs "lib/gdk-pixbuf-2.0/2.10.0/loaders.cache"))) `("XDG_DATA_DIRS" ":" prefix (,(string-append "/run/current-system/profile/share:" (getenv "XDG_DATA_DIRS")))) '("XCURSOR_PATH" ":" prefix ("/run/current-system/profile/share/icons")))))))) (native-inputs (list exo intltool pkg-config xfce4-dev-tools)) (inputs (list at-spi2-core bash-minimal ;for wrap-program gtk+ guile-3.0 (librsvg-for-system) libxklavier lightdm shared-mime-info)) (synopsis "GTK+ greeter for LightDM") (home-page "https://github.com/xubuntu/lightdm-gtk-greeter") (description "This package provides a LightDM greeter implementation using GTK+, lets you select a desktop session and log in to it.") (license license:gpl3+))) (define-public slim (package (name "slim") (version "1.4.1") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/slim-fork/slim-" version ".tar.gz")) (sha256 (base32 "06r47ypf9lsy76jikrvihw8ka9j2wbrnn8g3sbxp819hcbqxg22z")) (patches (search-patches "slim-config.patch" "slim-login.patch" "slim-display.patch")))) (build-system cmake-build-system) (inputs (list fontconfig freeglut freetype libjpeg-turbo libpng libx11 libxcrypt libxft libxmu libxrandr libxrender linux-pam xauth)) (native-inputs (list pkg-config)) (arguments (list #:phases #~(modify-phases %standard-phases (add-before 'configure 'set-new-etc-location (lambda _ (substitute* "CMakeLists.txt" (("/etc") (string-append #$output "/etc")) (("install.*SYSTEMDDIR.*") ;; The build system's logic here is: if "Linux", then ;; "systemd". Strip that. ""))))) #:configure-flags #~(list "-DUSE_PAM=yes" "-DUSE_CONSOLEKIT=no") #:tests? #f)) ;; The original project (https://github.com/iwamatsu/slim) has not been ;; maintained since 2013, so we use slim-fork instead. (home-page "https://slim-fork.sourceforge.io/") (synopsis "Desktop-independent graphical login manager for X11") (description "SLiM is a Desktop-independent graphical login manager for X11, derived from Login.app. It aims to be light and simple, although completely configurable through themes and an option file; is suitable for machines on which remote login functionalities are not needed. Features included: PNG and XFT support for alpha transparency and antialiased fonts, External themes support, Configurable runtime options: X server -- login / shutdown / reboot commands, Single (GDM-like) or double (XDM-like) input control, Can load predefined user at startup, Configurable welcome / shutdown messages, Random theme selection.") (license license:gpl2)))