aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-09-14 10:36:59 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-09-14 10:36:59 +0200
commit607280fa8fe26b500ad76a3769da8e4f917cae16 (patch)
treef7dc05c55ffb970dd621b1f4c6c87112d7bffe9a /gnu/packages
parent2cf45e9ef113b8a5d7a0e4c102b368fc15e8161c (diff)
downloadguix-607280fa8fe26b500ad76a3769da8e4f917cae16.tar.gz
guix-607280fa8fe26b500ad76a3769da8e4f917cae16.zip
gnu: smalltalk: Disable tests on x86-64.
* gnu/packages/smalltalk.scm (smalltalk)[arguments]: Disable tests on x86-64. Change-Id: I6838e94545df4c11f048b06dfbfd99358bf240a3
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/smalltalk.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/smalltalk.scm b/gnu/packages/smalltalk.scm
index 988410d93d..88a1bbc2c2 100644
--- a/gnu/packages/smalltalk.scm
+++ b/gnu/packages/smalltalk.scm
@@ -25,6 +25,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix utils)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
@@ -82,7 +83,10 @@
(inputs
(list gmp libffi libltdl libsigsegv lightning))
(arguments
- `(#:phases
+ `(;; FIXME: Tests fail on x86-64 in the build container, but they pass
+ ;; in a regular shell.
+ #:tests? ,(not (target-x86-64?))
+ #:phases
(modify-phases %standard-phases
;; XXX: To be removed with the next release of Smalltalk.
;; The overflow patch modifies configure.ac, therefore remove