aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 19:43:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:16 +0200
commit5bda5ec030ab76f6ba6d041e2d8fb7454e5e7e03 (patch)
tree46399182413b6d7ec2a649efb057a45e150111e2 /gnu/packages
parentfc11ada0ec8b7c288a463e0e6a6edeb479dc5089 (diff)
downloadguix-5bda5ec030ab76f6ba6d041e2d8fb7454e5e7e03.tar.gz
guix-5bda5ec030ab76f6ba6d041e2d8fb7454e5e7e03.zip
gnu: Add texlive-bibhtml.
* gnu/packages/tex.scm (texlive-bibhtml): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6b37373c0a..315a51875a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3356,6 +3356,30 @@ expand a BibTeX file, expanding the abbreviations (other than the built-in
ones like month names) and following the cross-references.")
(license license:lppl1.3+)))
+(define-public texlive-bibhtml
+ (package
+ (name "texlive-bibhtml")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bst/bibhtml/" "doc/bibtex/bibhtml/")
+ (base32
+ "0fjpipxc885hk9pvjf3f0wsp84lr1d7flvs5c56jmlvryvc6mv0w")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/bibhtml")
+ (synopsis "BibTeX support for HTML files")
+ (description
+ "Bibhtml consists of a Perl script and a set of BibTeX style files, which
+together allow you to output a bibliography as a collection of HTML files.
+The references in the text are linked directly to the corresponding
+bibliography entry, and if a URL is defined in the entry within the BibTeX
+database file, then the generated bibliography entry is linked to this. The
+package provides three different style files derived from each of the standard
+@file{plain.bst} and @file{alpha.bst}, as well as two style files derived from
+@file{abbrv.bst} and unsrt.bst (i.e., eight in total).")
+ (license license:gpl3+)))
+
(define-public texlive-bibleref
(package
(name "texlive-bibleref")