path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-05-12 16:43:04 -0500
committerEric Bavier <bavier@member.fsf.org>2014-05-12 17:20:32 -0500
commit5b527256ee8d280ec6f5d445522beb120005ad84 (patch)
treee617e262c08bde280332ecd66347180848f234c2 /gnu/packages
parenta37b807769cb5505384acd17d3f042398471f079 (diff)
downloadguix-5b527256ee8d280ec6f5d445522beb120005ad84.tar.gz
guix-5b527256ee8d280ec6f5d445522beb120005ad84.zip
gnu: openmpi: Use our hwloc.
* gnu/packages/mpi.scm (hwloc): Propagate numactl. (openmpi)[inputs]: Add hwloc. [native-inputs]: Add pkg-config. [argument]: Add hwloc configure flags.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mpi.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 071229214b..37b7858469 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -51,16 +51,16 @@
;; Enable libpci support, which effectively makes hwloc GPLv2+.
'(#:configure-flags '("--enable-libpci")))
(inputs
- `(("numactl" ,numactl)
- ("libx11" ,libx11)
+ `(("libx11" ,libx11)
("cairo" ,cairo)
("ncurses" ,ncurses)
("expat" ,expat)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(propagated-inputs
- ;; 'hwloc.pc' refers to libpci, hence the propagation.
- `(("pciutils" ,pciutils)))
+ ;; 'hwloc.pc' refers to libpci and libnuma, hence the propagation.
+ `(("numactl" ,numactl)
+ ("pciutils" ,pciutils)))
(home-page "http://www.open-mpi.org/projects/hwloc/")
(synopsis "Abstraction of hardware architectures")
(description
@@ -94,11 +94,14 @@ bind processes, and much more.")
(base32
"13z1q69f3qwmmhpglarfjminfy2yw4rfqr9jydjk5507q3mjf50p"))))
(build-system gnu-build-system)
- ;; TODO: Use our hwloc instead of the bundled one.
+ (inputs
+ `(("hwloc" ,hwloc)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(propagated-inputs
`(("gfortran" ,gfortran-4.8)))
(arguments
- `(#:configure-flags '("--enable-static"
+ `(#:configure-flags `("--enable-static"
"--enable-oshmem"
;; Thread support causes some applications to hang
;; "--enable-event-thread-support"
@@ -106,7 +109,9 @@ bind processes, and much more.")
;; "--enable-orte-progress-threads"
;; "--enable-mpi-thread-multiple"
"--enable-mpi-ext=all"
- "--with-devel-headers")))
+ "--with-devel-headers"
+ ,(string-append "--with-hwloc="
+ (assoc-ref %build-inputs "hwloc")))))
(home-page "http://www.open-mpi.org")
(synopsis "MPI-2 implementation")
(description
igure script
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (bin (find-files "." "\\.(bin|elf)$")))
- (for-each
- (lambda (file)
- (install-file file out))
- bin)))))
- #:make-flags (list (string-append "PLAT=" ,platform)
- ,@(if (and (not (string-prefix? "aarch64"
- (%current-system)))
- (string-prefix? "aarch64" arch))
- `("CROSS_COMPILE=aarch64-linux-gnu-")
- '())
- ,@(if (and (not (string-prefix? "armhf"
- (%current-system)))
- (string-prefix? "armhf" arch))
- `("CROSS_COMPILE=arm-linux-gnueabihf-")
- '())
- "DEBUG=1")
- #:tests? #f)) ; no tests
- (native-inputs
- (let ((system (%current-system)))
- (cond
- ((and (not (string-prefix? "aarch64" system))
- (string-prefix? "aarch64" arch))
- (list (cross-gcc "aarch64-linux-gnu")
- (cross-binutils "aarch64-linux-gnu")))
- ((and (not (string-prefix? "armhf" system))
- (string-prefix? "armhf" arch))
- (list (cross-gcc "arm-linux-gnueabihf")
- (cross-binutils "arm-linux-gnueabihf")))
- (else '()))))
- (home-page "https://www.trustedfirmware.org/")
- (synopsis "Implementation of \"secure world software\"")
- (description
- "ARM Trusted Firmware provides a reference implementation of secure world
+ (file-name (git-file-name "arm-trusted-firmware" version))
+ (sha256
+ (base32
+ "0grq3fgxi9xhcljnhwlxjvdghyz15gaq50raw41xy4lm8rkmnzp3"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ ;; Remove binary blobs which do not contain source or proper
+ ;; license.
+ (for-each (lambda (file)
+ (delete-file file))
+ (find-files "." "\\.bin$"))))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:target (and (not (native-build?)) triplet)
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (replace 'install
+ (lambda _
+ (for-each (lambda (file)
+ (install-file file #$output))
+ (find-files "." "\\.(bin|elf)$")))))
+ #:make-flags #~(list (string-append "PLAT=" #$platform)
+ #$@(if (not (native-build?))
+ (list (string-append "CROSS_COMPILE=" triplet "-"))
+ '())
+ "DEBUG=1")
+ #:tests? #f)) ;no test suite
+ (home-page "https://www.trustedfirmware.org/")
+ (synopsis "Implementation of \"secure world software\"")
+ (description
+ "ARM Trusted Firmware provides a reference implementation of secure world
software for ARMv7A and ARMv8-A, including a Secure Monitor executing at
@dfn{Exception Level 3} (EL3). It implements various ARM interface standards,
such as:
@@ -1018,8 +1006,8 @@ such as:
@item System Control and Management Interface
@item Software Delegated Exception Interface (SDEI)
@end enumerate\n")
- (license (list license:bsd-3
- license:bsd-2)))) ; libfdt
+ (license (list license:bsd-3
+ license:bsd-2))))) ; libfdt
(define-public arm-trusted-firmware-sun50i-a64
(let ((base (make-arm-trusted-firmware "sun50i_a64")))