aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-12-21 13:25:06 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-21 13:25:06 +0100
commit5aef68575f1a89bc98bcd9bbe82425a3f82106f8 (patch)
treef0e065f774b46a02ac86dbe28100d85ab7c8adc9 /gnu/packages
parent940e79fc18e25d5a47afab82bd50bb261ae99fef (diff)
downloadguix-5aef68575f1a89bc98bcd9bbe82425a3f82106f8.tar.gz
guix-5aef68575f1a89bc98bcd9bbe82425a3f82106f8.zip
gnu: Add rust-c2rust-bitfields-derive.
* gnu/packages/c2rust.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Change-Id: Id65ff99ef166152217c6b16b38a56a9329e28d53
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/c2rust.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/c2rust.scm b/gnu/packages/c2rust.scm
new file mode 100644
index 0000000000..b2f97e2521
--- /dev/null
+++ b/gnu/packages/c2rust.scm
@@ -0,0 +1,58 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Danny Milosavljevic <dannym@friendly-machines.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages c2rust)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system cargo)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix gexp)
+ #:use-module (guix utils)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages cmake)
+ #:use-module (gnu packages crates-io)
+ #:use-module (gnu packages crates-vcs)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages llvm)
+ #:use-module ((guix licenses) #:prefix license:))
+
+(define-public rust-c2rust-bitfields-derive-0.18
+ (package
+ (name "rust-c2rust-bitfields-derive")
+ (version "0.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "c2rust-bitfields-derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0i95j6q1d61h1m1pk84i3ih00hsmbn8ib35xr129fz2rw81c3jyk"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))))
+ (home-page "https://c2rust.com/")
+ (synopsis
+ "C-compatible struct bitfield derive implementation used in the C2Rust project")
+ (description
+ "This package provides C-compatible struct bitfield derive implementation used in the C2Rust project.")
+ (license license:bsd-3)))