aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-28 23:48:55 +0000
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-01 10:27:36 +0300
commit58344dfb0ec1972946f1a9f38880e2875287fad6 (patch)
tree972553e7c149e6d2715c80607bb9af6aaf02194b /gnu/packages
parent1fb40a5b920fa856fe4b9ad85b7da74d75b9f769 (diff)
downloadguix-58344dfb0ec1972946f1a9f38880e2875287fad6.tar.gz
guix-58344dfb0ec1972946f1a9f38880e2875287fad6.zip
gnu: Add go-github-com-atotto-clipboard.
* gnu/packages/golang-xyz.scm (go-github-com-atotto-clipboard): New variable. Change-Id: I4a871983f564034045f4b2ba77f2453cfce5cb2b Reviewed-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm37
1 files changed, 36 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 1dc7849edb..daafc1285c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -85,7 +85,9 @@
#:use-module (gnu packages golang-maths)
#:use-module (gnu packages golang-web)
#:use-module (gnu packages linux)
- #:use-module (gnu packages specifications))
+ #:use-module (gnu packages specifications)
+ #:use-module (gnu packages xdisorg)
+ #:use-module (gnu packages xorg))
;;; Commentary:
;;;
@@ -981,6 +983,39 @@ collections. It was based on
@url{https://github.com/chriso/validator.js,validator.js}.")
(license license:expat)))
+(define-public go-github-com-atotto-clipboard
+ (package
+ (name "go-github-com-atotto-clipboard")
+ (version "0.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/atotto/clipboard")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ycd8zkgsq9iil9svhlwvhcqwcd7vik73nf8rnyfnn10gpjx97k5"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/atotto/clipboard"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'start-xorg-server
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; The test suite requires a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1"))))))
+ (native-inputs
+ (list xorg-server-for-tests))
+ (propagated-inputs (list xclip))
+ (home-page "https://github.com/atotto/clipboard")
+ (synopsis "Clipboard for Golang")
+ (description
+ "@code{clipboard} provides copying and pasting to the clipboard for Go.")
+ (license license:bsd-3)))
+
(define-public go-github-com-audriusbutkevicius-recli
(package
(name "go-github-com-audriusbutkevicius-recli")