aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-18 20:54:13 +0200
committerMarius Bakke <marius@gnu.org>2022-09-08 21:40:00 +0200
commit56759d30d9a817a9c9221c9468a4c4a59c9a4713 (patch)
tree21dad792e455f3ead29be85963866aefa4ff9f28 /gnu/packages
parent3c8b6fd94ceb1e898216929e8768fb518dbf1de9 (diff)
downloadguix-56759d30d9a817a9c9221c9468a4c4a59c9a4713.tar.gz
guix-56759d30d9a817a9c9221c9468a4c4a59c9a4713.zip
gnu: Switch to GCC 11.
* gnu/packages/commencement.scm (gcc-boot0)[source]: Delete offending files from GCC. (libstdc++-boot0)[arguments]: Add #:modules. (libstdc++): Inherit from from GCC-BOOT0 rather than GCC. (gcc-final)[arguments]: Add phase to workaround libstdc++ build system issue. Add #:modules. * gnu/packages/gcc.scm (make-libstdc++): Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/commencement.scm55
-rw-r--r--gnu/packages/gcc.scm33
2 files changed, 77 insertions, 11 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index c03b9554a5..b54c21b258 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2220,7 +2220,13 @@ exec " gcc "/bin/" program
(lambda _
(substitute* "libstdc++-v3/configure"
(("g\\+\\+ -v") "true"))))))))
- (_ (package-arguments lib)))))
+ (_ (package-arguments lib)))
+
+ ;; Explicitly add #:modules so MAKE-LIBSTDC++ can be changed
+ ;; without a full bootstrap.
+ #:modules ((guix build gnu-build-system)
+ (guix build utils))))
+
(inputs (%boot0-inputs))
(native-inputs '()))))
@@ -2273,7 +2279,18 @@ exec " gcc "/bin/" program
(inherit gcc)
(name "gcc-cross-boot0")
(outputs (delete "debug" (package-outputs gcc)))
- (source (bootstrap-origin (package-source gcc)))
+ (source
+ (bootstrap-origin
+ (origin
+ (inherit (package-source gcc))
+ (snippet
+ #~(begin
+ ;; XXX: The GCC test suite contains files with non-ASCII file
+ ;; names, which cannot be repacked by BOOTSTRAP-ORIGIN. Nor
+ ;; can it be deleted from Guile, so resort to this evil hack.
+ #$(origin-snippet (package-source gcc))
+ (system* #$(file-append coreutils-boot0 "/bin/rm") "-rf"
+ "gcc/testsuite/go.test/test/fixedbugs/issue27836.dir"))))))
(arguments
`(#:guile ,%bootstrap-guile
#:implicit-inputs? #f
@@ -2998,7 +3015,7 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(define libstdc++
;; Intermediate libstdc++ that will allow us to build the final GCC
;; (remember that GCC-BOOT0 cannot build libstdc++.)
- (let ((lib (make-libstdc++ gcc)))
+ (let ((lib (make-libstdc++ gcc-boot0)))
(package
(inherit lib)
(source (bootstrap-origin (package-source lib)))
@@ -3066,6 +3083,11 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
;; positive, so turn it off.
#:validate-runpath? #f
+ ;; Additional modules for the libstdc++ phase below.
+ #:modules ((srfi srfi-1)
+ (srfi srfi-26)
+ ,@%gnu-build-system-modules)
+
,@(substitute-keyword-arguments (package-arguments gcc)
((#:make-flags flags)
;; Since $LIBRARY_PATH is not honored, add the relevant flags.
@@ -3103,7 +3125,26 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(package-full-name lib "-")
char-set:letter)
,(package-name lib)))
- (list gmp-6.0 mpfr mpc))))))))))
+ (list gmp-6.0 mpfr mpc)))))
+ (add-after 'unpack 'fix-build-with-external-libstdc++
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libstdc++ (assoc-ref inputs "libstdc++")))
+ ;; Fix a regression in GCC 11 where the libstc++ input
+ ;; shadows glibc headers when building libstdc++. An
+ ;; upstream fix was added in GCC 11.3.0, but it only
+ ;; hides system include directories, not those on
+ ;; CPLUS_INCLUDE_PATH. See discussion at
+ ;; <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100017>.
+ (substitute* "libstdc++-v3/src/c++17/Makefile.in"
+ (("AM_CXXFLAGS = ")
+ (string-append "CPLUS_INCLUDE_PATH = "
+ (string-join
+ (remove (cut string-prefix? libstdc++ <>)
+ (string-split
+ (getenv "CPLUS_INCLUDE_PATH")
+ #\:))
+ ":")
+ "\nAM_CXXFLAGS = ")))))))))))
;; This time we want Texinfo, so we get the manual. Add
;; STATIC-BASH-FOR-GLIBC so that it's used in the final shebangs of
@@ -3414,10 +3455,10 @@ is the GNU Compiler Collection.")
(make-gcc-toolchain gcc-9))
(define-public gcc-toolchain-10
- gcc-toolchain)
+ (make-gcc-toolchain gcc-10))
(define-public gcc-toolchain-11
- (make-gcc-toolchain gcc-11))
+ gcc-toolchain)
(define-public gcc-toolchain-12
(make-gcc-toolchain gcc-12))
@@ -3425,7 +3466,7 @@ is the GNU Compiler Collection.")
(define-public gcc-toolchain-aka-gcc
;; It's natural for users to try "guix install gcc". This package
;; automatically "redirects" them to 'gcc-toolchain'.
- (deprecated-package "gcc" gcc-toolchain-10))
+ (deprecated-package "gcc" gcc-toolchain-11))
(define-public gdc-toolchain-10
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index b6854813d7..80eaec722a 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
@@ -718,7 +718,7 @@ It also includes runtime support libraries for these languages.")
;; Note: When changing the default gcc version, update
;; the gcc-toolchain-* definitions.
-(define-public gcc gcc-10)
+(define-public gcc gcc-11)
;;;
@@ -821,8 +821,33 @@ using compilers other than GCC."
(name "libstdc++")
(arguments
`(#:out-of-source? #t
+ #:modules ((srfi srfi-1)
+ (srfi srfi-26)
+ ,@%gnu-build-system-modules)
#:phases
(modify-phases %standard-phases
+ ,@(if (version>=? (package-version gcc) "11")
+ '((add-after 'unpack 'hide-gcc-headers
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (let ((gcc (assoc-ref (or native-inputs inputs) "gcc")))
+ ;; Fix a regression in GCC 11 where the GCC headers
+ ;; shadows glibc headers when building libstdc++. An
+ ;; upstream fix was added in GCC 11.3.0, but it only
+ ;; hides system include directories, not those on
+ ;; CPLUS_INCLUDE_PATH. See discussion at
+ ;; <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100017>
+ ;; and the similar adjustment in GCC-FINAL.
+ (substitute* "libstdc++-v3/src/c++17/Makefile.in"
+ (("AM_CXXFLAGS = ")
+ (string-append "CPLUS_INCLUDE_PATH = "
+ (string-join
+ (remove (cut string-prefix? gcc <>)
+ (string-split
+ (getenv "CPLUS_INCLUDE_PATH")
+ #\:))
+ ":")
+ "\nAM_CXXFLAGS = ")))))))
+ '())
;; Force rs6000 (i.e., powerpc) libdir to be /lib and not /lib64.
(add-before 'chdir 'fix-rs6000-libdir
(lambda _
@@ -1109,7 +1134,7 @@ provides the GNU compiler for the Go programming language."))
(custom-gcc gcc-12 "gcc-objc" '("objc")
%objc-search-paths))
-(define-public gcc-objc gcc-objc-10)
+(define-public gcc-objc gcc-objc-11)
(define %objc++-search-paths
(list (search-path-specification
@@ -1159,7 +1184,7 @@ provides the GNU compiler for the Go programming language."))
(custom-gcc gcc-12 "gcc-objc++" '("obj-c++")
%objc++-search-paths))
-(define-public gcc-objc++ gcc-objc++-10)
+(define-public gcc-objc++ gcc-objc++-11)
(define (make-libstdc++-doc gcc)
"Return a package with the libstdc++ documentation for GCC."