aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-08 00:32:22 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:43 +0000
commit565f483ef0def11c88ecd6ee0c5bb6ac650690d4 (patch)
tree385318ee0eae3093cac30436ffd92457ba42d5b9 /gnu/packages
parent273e52723965088bacfb86d5e5be3e1c3e62cc76 (diff)
downloadguix-565f483ef0def11c88ecd6ee0c5bb6ac650690d4.tar.gz
guix-565f483ef0def11c88ecd6ee0c5bb6ac650690d4.zip
gnu: python-openapi-spec-validator: Update to 0.7.1.
* gnu/packages/python-web.scm (python-openapi-spec-validator): Update to 0.7.1. [arguments]: Update test selection. [propagated-inputs]: Add python-jsonschema-path and python-lazy-object-proxy. Change-Id: Ie10257a90b495addf3ea890cf9b3c71c6f14da8f
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e41a60ab58..689c0478b3 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2271,7 +2271,7 @@ JSON Schema Specification Draft 2020-12.
(define-public python-openapi-spec-validator
(package
(name "python-openapi-spec-validator")
- (version "0.4.0")
+ (version "0.7.1")
(source
(origin
(method git-fetch) ;no tests in pypi release
@@ -2281,22 +2281,26 @@ JSON Schema Specification Draft 2020-12.
(file-name (git-file-name name version))
(sha256
(base32
- "1q09sjh4hsc0c8yqbd97h5mp6rwh427y6zyn8kv8wljk6sa0fs4q"))))
+ "0s5yd4dbr6knwd2g1g4v2931k14n1lm80l11n2ija18yfis8yisz"))))
(build-system pyproject-build-system)
(arguments
(list
- ;; The example tests attempt to fetch resources from the Internet
- ;; (see: https://github.com/p1c2u/openapi-spec-validator/issues/151).
- #:test-flags #~'("-k" "not Example and not Exampe")
+ ;; These tests attempt to fetch resources from the Internet
+ #:test-flags '(list "--ignore-glob=tests/integration/validation/**"
+ "-k" "not example")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'remove-coverage-pytest-options
(lambda _
(substitute* "pyproject.toml"
(("^--cov.*") "")))))))
- (native-inputs (list python-poetry-core python-pytest))
+ (native-inputs
+ (list python-poetry-core
+ python-pytest))
(propagated-inputs
(list python-jsonschema
+ python-jsonschema-path
+ python-lazy-object-proxy
python-openapi-schema-validator
python-pyyaml
python-requests