aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-04-27 10:38:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-04-27 10:40:23 +0200
commit5135354f62765ec41edaab541f519888b8e197f8 (patch)
treee9b7d561fd3d18b689cd6bcd079893f3edcdbb45 /gnu/packages
parent416381daa2f73a06a7af324032413d9de46bbfb3 (diff)
downloadguix-5135354f62765ec41edaab541f519888b8e197f8.tar.gz
guix-5135354f62765ec41edaab541f519888b8e197f8.zip
gnu: python-ly: Update to 0.9.4.
* gnu/packages/python.scm (python-ly): Update to 0.9.4.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3266613b97..f79fd744be 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5380,16 +5380,16 @@ from an XML-based format.")
(define-public python-ly
(package
(name "python-ly")
- (version "0.9.3")
+ (version "0.9.4")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://pypi.python.org/packages/source/p/python-ly/python-ly-"
- version ".tar.gz"))
+ (uri (string-append "https://pypi.python.org/packages/57/4f/"
+ "889579244947368f28eda66b782331b1e75f83fd72e63f9ece93cd7a18f9"
+ "/python-ly-" version ".tar.gz"))
(sha256
(base32
- "1y6ananq8fia4y4m5id6gvsrm68bzpzd1y46pfzvawic0wjg2l0l"))))
+ "0g6n288l83sfwavxh1aryi0aqvsr3sp7v6f903mckwqa4scpky62"))))
(build-system python-build-system)
(native-inputs
`(("python-setuptools" ,python-setuptools)))
dency-variables): Remove %libgcrypt. (make-config.scm): Remove #:libgcrypt. * build-aux/build-self.scm (guile-gcrypt): New variable. (make-config.scm): Remove #:libgcrypt. (build-program)[fake-gcrypt-hash]: New variable. Add (gcrypt hash) to the imported modules. Adjust load path assignments. * gnu/packages/package-management.scm (guix)[propagated-inputs]: Add GUILE-GCRYPT. [arguments]: In 'wrap-program' phase, add GUILE-GCRYPT to the search path. Ludovic Courtès 2018-08-24import: cpan: Adjust test to new URL....This is a followup to 9aba9b127840a116c806a2cbac901cf8077abcd0. * tests/cpan.scm ("cpan->guix-package"): Adjust 'home-page' URL. Ludovic Courtès 2017-10-30Revert "import: cpan: Use HTTPS for home pages."...This reverts commit 29f7bf59d5d4d4b848eaedc6766bb4e02cae20d3: HTTPS support at search.cpan.org is unreliable, at best. Don't rely on it. Tobias Geerinckx-Rice 2017-10-29import: cpan: Use HTTPS for home pages....* guix/import/cpan.scm (cpan-home): Use HTTPS. * tests/cpan.scm ("cpan->guix-package"): Expect it. Tobias Geerinckx-Rice 2017-10-28import: cpan: Add trailing "/" on home-page....This appeases 'guix lint', which otherwise complains about permanent redirects. * guix/import/cpan.scm (cpan-module->sexp): Add trailing "/" on home-page. * tests/cpan.scm ("cpan->guix-package"): Adjust accordingly. Eric Bavier 2017-10-28import: cpan: Propagate imported dependencies....This is most often the need for perl module dependencies. * guix/import/cpan.scm (cpan-module->sexp): 'inputs -> 'propagated-inputs. * tests/cpan.scm ("cpan->guix-package"): Adjust accordingly. Eric Bavier 2017-09-14import: cpan: Adjust expected license in tests....This is a followup to 01ef804d69b2e57dd7b1d3d13e66e3f67e7c548a. * tests/cpan.scm ("cpan->guix-package"): Expect 'perl-license'. Ludovic Courtès 2017-06-07import: cpan: Update CPAN importer to use MetaCPAN v1 API....* guix/import/cpan.scm (module->dist-name, cpan-fetch): Use metacpan.org URLs. * tests/cpan.scm ("cpan->guix-package"): Adjust accordingly. Signed-off-by: Ludovic Courtès <ludo@gnu.org> James Richardson 2017-02-13tests: Adjust for 'http-fetch' change in (guix import json)....This is a followup to commit 81e0bc1834490a1a8092c75a0733b15c2b407285. * tests/cpan.scm ("cpan->guix-package"): Add a 'rest' argument to the lambda that mocks 'http-fetch'. * tests/crate.scm ("crate->guix-package"): Likewise. * tests/gem.scm ("gem->guix-package"): Likewise. * tests/pypi.scm ("pypi->guix-package"): Likewise. ("pypi->guix-package, wheels"): Likewise. Ludovic Courtès 2016-12-18tests: Mock up http-fetch....This is a follow-up to commit 63773200d7ac68fcaee6efd9ffe8ea7aa3fafa38. * tests/cpan.scm ("cpan->guix-package"): Add mock definition of http-fetch. Ricardo Wurmus 2016-12-18tests: Adjust cpan tests....This is a follow-up to commit ff55fe559951b88bfd691b9dada3a0f26002c4cb. * tests/cpan.scm (source-url-http, source-url-https): Use cpan-source-url. Ricardo Wurmus 2016-11-10tests: Adjust 'url-fetch' mocks to TLS changes....This is a followup to bc3c41ce36349ed4ec758c70b48a7059e363043a. * tests/cpan.scm ("cpan->guix-package"): Add #:verify-certificate? parameter in 'url-fetch' mock. * tests/cran.scm ("description->package"): Likewise. Ludovic Courtès 2016-08-31tests: cpan: Fix mock urls....Followup to 7a62263ee5. * tests/cpan.scm (cpan->guix-package): Use "https" in mock urls. Eric Bavier