aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-28 23:49:01 +0000
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-01 10:27:39 +0300
commit4fe2cb289fc545e7fc19cc87fcac8d2d047201d4 (patch)
tree6846aeb807cda2ad43f12b66537cd62e5038c7f3 /gnu/packages
parent222f672ca3e798669b1d739bd35bff7cf028bc29 (diff)
downloadguix-4fe2cb289fc545e7fc19cc87fcac8d2d047201d4.tar.gz
guix-4fe2cb289fc545e7fc19cc87fcac8d2d047201d4.zip
gnu: Add go-github-com-charmbracelet-x-exp-golden.
* gnu/packages/golang-xyz.scm (go-github-com-charmbracelet-x-exp-golden): New variable. Change-Id: I7fa815433d9a83e4562bdc769312dd05e0a298da Reviewed-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 729d4020b9..3002144ffd 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1612,6 +1612,48 @@ tools.")
ECMA-48} specs.")
(license license:expat)))
+(define-public go-github-com-charmbracelet-x-exp-golden
+ (package
+ (name "go-github-com-charmbracelet-x-exp-golden")
+ (version "0.0.0-20241121171228-5bc00623ea2f")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/charmbracelet/x")
+ (commit (go-version->git-ref version
+ #:subdir "exp/golden"))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "016s67690dr3w3an6m24q6f4vrmwpk0qd4akvvh1dzpfyf4khxd4"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/charmbracelet/x/exp/golden"
+ #:unpack-path "github.com/charmbracelet/x/"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda* (#:key import-path #:allow-other-keys)
+ ;; Tests need to write to that files.
+ (with-directory-excursion (string-append "src/" import-path)
+ (make-file-writable "testdata/TestRequireEqualUpdate.golden")
+ (make-file-writable "testdata/TestRequireEqualNoUpdate.golden"))))
+ (add-after 'check 'post-check
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ ;; Remove modified testdata just in case.
+ (delete-file-recursively "testdata")))))))
+ (propagated-inputs
+ (list go-github-com-aymanbagabas-go-udiff))
+ (home-page "https://github.com/charmbracelet/x")
+ (synopsis "Verify @code{.golden} file equality")
+ (description
+ "Golden files (@code{.golden}) contain the raw expected output of
+tests,which can contain control codes and escape sequences. @code{golden}
+package provides an API for comparing Golden files.")
+ (license license:expat)))
+
(define-public go-github-com-chzyer-logex
(package
(name "go-github-com-chzyer-logex")