aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:22:43 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:06 +0200
commit4f8fd64cf5b4d61ee30049268f4b0a61266f0e0e (patch)
tree0df184f197297484a7f81695750d30f1dc3564e7 /gnu/packages
parentb625752d03a78afc99eeca4299dc547bf5982449 (diff)
downloadguix-4f8fd64cf5b4d61ee30049268f4b0a61266f0e0e.tar.gz
guix-4f8fd64cf5b4d61ee30049268f4b0a61266f0e0e.zip
gnu: emacs-monroe: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-monroe)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1ba61a3d46..319442fc5a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5608,19 +5608,19 @@ used for reverse direction.")
(name "emacs-monroe")
(version "0.3.1")
(source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/sanel/monroe/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0icdx8shkd951phlnmcq1vqaxp1l667q5rjscskc5r22aylakh4w"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sanel/monroe.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "101lfrykdbv37spkbw7zihhx26bc1lhjyxbanrcp9880bxj04jiy"))))
(build-system emacs-build-system)
(home-page "https://github.com/sanel/monroe")
(synopsis "Clojure nREPL client for Emacs")
(description
- "Monroe is a nREPL client for Emacs, focused on simplicity and easy
+ "Monroe is a nREPL client for Emacs, focused on simplicity and easy
distribution, primarily targeting Clojure users")
(license license:gpl3+)))