aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-08-08 14:18:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-08 14:28:24 +0200
commit4e8d9015e06ca3ea432da1b53f7518c767d32a11 (patch)
tree98efd5624197b93ec19dee4f118e0a20469ea407 /gnu/packages
parentd60869805e313f2a733aa7a69932f1c5d2224845 (diff)
downloadguix-4e8d9015e06ca3ea432da1b53f7518c767d32a11.tar.gz
guix-4e8d9015e06ca3ea432da1b53f7518c767d32a11.zip
gnu: e2fsprogs: Update to 1.44.3.
* gnu/packages/linux.scm (e2fsprogs): Update to 1.44.3. * gnu/packages/patches/e2fsprogs-glibc-2.27.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm5
-rw-r--r--gnu/packages/patches/e2fsprogs-glibc-2.27.patch56
2 files changed, 2 insertions, 59 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3adc0d68e0..3665080218 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -732,7 +732,7 @@ slabtop, and skill.")
(define-public e2fsprogs
(package
(name "e2fsprogs")
- (version "1.43.6")
+ (version "1.44.3")
(source (origin
(method url-fetch)
(uri (string-append
@@ -741,8 +741,7 @@ slabtop, and skill.")
name "-" version ".tar.xz"))
(sha256
(base32
- "00ilv65dzcgiap435j89xk86shf7rrav3wsik7cahy789qijdcn9"))
- (patches (search-patches "e2fsprogs-glibc-2.27.patch"))))
+ "1djb9qnid1j0vvna2bhq4jsz2ig1xckbx7h4d86cr0gl61yrz2ax"))))
(build-system gnu-build-system)
(inputs `(("util-linux" ,util-linux)))
(native-inputs `(("pkg-config" ,pkg-config)
diff --git a/gnu/packages/patches/e2fsprogs-glibc-2.27.patch b/gnu/packages/patches/e2fsprogs-glibc-2.27.patch
deleted file mode 100644
index f0bc7130c0..0000000000
--- a/gnu/packages/patches/e2fsprogs-glibc-2.27.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-Copied from:
-https://github.com/openwrt/openwrt/blob/58a95f0f8ff768b43d68eed2b6a786e0f40f723b/tools/e2fsprogs/patches/005-misc-rename-copy_file_range-to-copy_file_chunk.patch
-
-From 01551bdba16ab16512a01affe02ade32c41ede8a Mon Sep 17 00:00:00 2001
-From: Palmer Dabbelt <palmer@dabbelt.com>
-Date: Fri, 29 Dec 2017 10:19:51 -0800
-Subject: [PATCH] misc: rename copy_file_range to copy_file_chunk
-
-As of 2.27, glibc will have a copy_file_range library call to wrap the
-new copy_file_range system call. This conflicts with the function in
-misc/create_inode.c, which this patch renames _copy_file_range.
-
-Signed-off-by: Palmer Dabbelt <palmer@dabbelt.com>
-Signed-off-by: Theodore Ts'o <tytso@mit.edu>
----
- misc/create_inode.c | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
---- a/misc/create_inode.c
-+++ b/misc/create_inode.c
-@@ -392,7 +392,7 @@ static ssize_t my_pread(int fd, void *bu
- }
- #endif /* !defined HAVE_PREAD64 && !defined HAVE_PREAD */
-
--static errcode_t copy_file_range(ext2_filsys fs, int fd, ext2_file_t e2_file,
-+static errcode_t copy_file_chunk(ext2_filsys fs, int fd, ext2_file_t e2_file,
- off_t start, off_t end, char *buf,
- char *zerobuf)
- {
-@@ -466,7 +466,7 @@ static errcode_t try_lseek_copy(ext2_fil
-
- data_blk = data & ~(fs->blocksize - 1);
- hole_blk = (hole + (fs->blocksize - 1)) & ~(fs->blocksize - 1);
-- err = copy_file_range(fs, fd, e2_file, data_blk, hole_blk, buf,
-+ err = copy_file_chunk(fs, fd, e2_file, data_blk, hole_blk, buf,
- zerobuf);
- if (err)
- return err;
-@@ -516,7 +516,7 @@ static errcode_t try_fiemap_copy(ext2_fi
- }
- for (i = 0, ext = ext_buf; i < fiemap_buf->fm_mapped_extents;
- i++, ext++) {
-- err = copy_file_range(fs, fd, e2_file, ext->fe_logical,
-+ err = copy_file_chunk(fs, fd, e2_file, ext->fe_logical,
- ext->fe_logical + ext->fe_length,
- buf, zerobuf);
- if (err)
-@@ -569,7 +569,7 @@ static errcode_t copy_file(ext2_filsys f
- goto out;
- #endif
-
-- err = copy_file_range(fs, fd, e2_file, 0, statbuf->st_size, buf,
-+ err = copy_file_chunk(fs, fd, e2_file, 0, statbuf->st_size, buf,
- zerobuf);
- out:
- ext2fs_free_mem(&zerobuf);