aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-06-04 17:42:41 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-22 13:19:02 +0100
commit4dc4e057b44f9171975ffaf066fd884c754c325b (patch)
treecbcd1f41aacb70b07d874d022bba3d5afdad7605 /gnu/packages
parent9eaecd260cd42b5f3a9d45aec8b306f921ee628c (diff)
downloadguix-4dc4e057b44f9171975ffaf066fd884c754c325b.tar.gz
guix-4dc4e057b44f9171975ffaf066fd884c754c325b.zip
gnu: Add geolite-country-data.
* gnu/packages/perl-web.scm (geolite-country-data): New variable. Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl-web.scm b/gnu/packages/perl-web.scm
index b4c89d1947..393cbc4d06 100644
--- a/gnu/packages/perl-web.scm
+++ b/gnu/packages/perl-web.scm
@@ -25,6 +25,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (guix download)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system perl)
#:use-module (gnu packages web))
@@ -232,3 +233,30 @@ simple and lightweight interface to the
@acronym{SOAP, Simple Object Access Protocol}, both on client and server
side.")
(license license:perl-license)))
+
+(define-public geolite-country-data
+ ;; TODO: Figure out how to get an updated, free database.
+ (hidden-package
+ (package
+ (name "geolite-country-data")
+ (version "2019-12-06")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://web.archive.org/web/20181229152721/"
+ "http://geolite.maxmind.com/download/geoip/database/"
+ "GeoLiteCountry/" "GeoIP.dat.gz"))
+ (sha256
+ (base32
+ "0j84ms2x893cpn7x8gffy082gnx882pmr0f6zpfsd46gpyw5xh5r"))))
+ (build-system copy-build-system)
+ (arguments
+ (list #:install-plan #~'(("GeoIP.dat" "share/GeoIP/"))))
+ (home-page "https://dev.maxmind.com/geoip/geolite2-free-geolocation-data")
+ (synopsis "Country-level GeoIP data (December 2018)")
+ (description
+ "This package provides an old GeoIP database in the legacy @file{.dat}
+format. The data was collected before MaxMind changed the license and format
+of their databases. It is intended only as a compatability package for
+SpamAssassin.")
+ (license license:cc-by-sa4.0))))