aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-08-18 16:32:45 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:46 +0200
commit4d8382ab840300ffe2a364d0e2a27b8db3d04fab (patch)
treec39882cb7d4a24a68735ef03c8b726d7384901b6 /gnu/packages
parent4f55c361f4f844daa661d9907b4e1e6275468e58 (diff)
downloadguix-4d8382ab840300ffe2a364d0e2a27b8db3d04fab.tar.gz
guix-4d8382ab840300ffe2a364d0e2a27b8db3d04fab.zip
gnu: gsl: Fix test failures on i686-linux by building with -O2.
* gnu/packages/maths.scm (gsl)[arguments]: Pass #:make-flags '() on i686-linux. Remove modification of ‘linalg/test.c’ in ‘disable-failing-tests’ phase for i686-linux. Change-Id: I615d4e0d71253ca294bc5c5c7a278e3046c186cc
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ad81263e9c..76aec6b250 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -729,7 +729,16 @@ precision floating point numbers.")
(build-system gnu-build-system)
(arguments
(let ((system (%current-system)))
- `(#:make-flags (list "CFLAGS=-fPIC")
+ `(;; FIXME: Setting CFLAGS=-fPIC is not only unnecessary, it's also
+ ;; harmful because it removes the default '-O2 -g', meaning that the
+ ;; library ends up being compiled as -O0. Consequently, some
+ ;; numerical tests fail, notably on i686-linux. TODO: Remove
+ ;; 'CFLAGS=-fPIC' for all systems and revisit or remove
+ ;; 'disable-failing-tests' phases accordingly.
+ #:make-flags ,(if (and (not (%current-target-system))
+ (string=? system "i686-linux"))
+ ''()
+ '(list "CFLAGS=-fPIC"))
#:phases
(modify-phases %standard-phases
,@(cond
@@ -756,13 +765,6 @@ precision floating point numbers.")
;; https://lists.gnu.org/archive/html/bug-gsl/2020-04/msg00000.html
'((add-before 'check 'disable-failing-tests
(lambda _
- (substitute* "linalg/test.c"
- ((".*gsl_test\\(test_LU_decomp.*") "\n")
- ((".*gsl_test\\(test_LUc_decomp.*") "\n")
- ((".*gsl_test\\(test_QR_decomp_r.*") "\n")
- ((".*gsl_test\\(test_cholesky_decomp.*") "\n")
- ((".*gsl_test\\(test_pcholesky_solve.*") "\n")
- ((".*gsl_test\\(test_COD_lssolve2.*") "\n"))
(substitute* "spmatrix/test.c"
((".*test_all.*") "\n")
((".*test_float.*") "\n")