aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 17:03:59 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:46 +0200
commit4ce0414bca13f609db27371a4f75c6e37111d10f (patch)
treee2367f4c7084c09e0401a66c8fe2744296462015 /gnu/packages
parent5e2f74bdb847db3b4dd429efcacd6dd4432a771b (diff)
downloadguix-4ce0414bca13f609db27371a4f75c6e37111d10f.tar.gz
guix-4ce0414bca13f609db27371a4f75c6e37111d10f.zip
gnu: Add ruby-rouge.
* gnu/packages/ruby.scm (ruby-rouge): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 024a99ab4c..e605f3e6de 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5685,3 +5685,26 @@ parser for writing http servers, clients and proxies.")
(description "Em-websocket is an EventMachine based WebSocket server
implementation.")
(license license:expat)))
+
+(define-public ruby-rouge
+ (package
+ (name "ruby-rouge")
+ (version "3.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rouge" version))
+ (sha256
+ (base32
+ "0h79gn2wmn1wix2d27lgiaimccyj8gvizrllyym500pir408x62f"))))
+ (build-system ruby-build-system)
+ (arguments `(#:tests? #f)); No rakefile
+ (home-page "http://rouge.jneen.net/")
+ (synopsis "Code highlighter")
+ (description "Rouge is a code highlighter written in Ruby. It supports more
+than 100 languages and outputs HTML or ANSI 256-color text. Its HTML output
+is compatible with stylesheets designed for pygments.")
+ (license (list
+ ;; rouge is licensed under expat
+ license:expat
+ ;; pygments is licensed under bsd-2
+ license:bsd-2))))
or data streams without having to be cryptographers. The companion to MCrypt is Libmcrypt, which contains the actual encryption functions themselves, and provides a standardized mechanism for accessing them.") (license gpl2+))) (define-public libmcrypt (package (name "libmcrypt") (version "2.5.8") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/mcrypt/libmcrypt-" version ".tar.gz")) (sha256 (base32 "0gipgb939vy9m66d3k8il98rvvwczyaw2ixr8yn6icds9c3nrsz4")))) (build-system gnu-build-system) (native-inputs `(("file" ,file))) (home-page "http://mcrypt.sourceforge.net/") (synopsis "Encryption algorithm library") (description "Libmcrypt is a data encryption library. The library is thread safe and provides encryption and decryption functions. This version of the library supports many encryption algorithms and encryption modes. Some algorithms which are supported: SERPENT, RIJNDAEL, 3DES, GOST, SAFER+, CAST-256, RC2, XTEA, 3WAY, TWOFISH, BLOWFISH, ARCFOUR, WAKE and more.") (license gpl2+))) (define-public libmhash (package (name "libmhash") (version "0.9.9.9") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/mhash/mhash-" version ".tar.bz2")) (sha256 (base32 "1w7yiljan8gf1ibiypi6hm3r363imm3sxl1j8hapjdq3m591qljn")) (patches (list (search-patch "mhash-keygen-test-segfault.patch"))))) (build-system gnu-build-system) (native-inputs `(("file" ,file) ("perl" ,perl))) ;for tests (home-page "http://mhash.sourceforge.net/") (synopsis "Thread-safe hash library") (description "mhash is a thread-safe hash library, implemented in C, and provides a uniform interface to a large number of hash algorithms. These algorithms can be used to compute checksums, message digests, and other signatures. The HMAC support implements the basics for message authentication, following RFC 2104. Algorithms currently supplied are: CRC-32, CRC-32B, ALDER-32, MD-2, MD-4, MD-5, RIPEMD-128, RIPEMD-160, RIPEMD-256, RIPEMD-320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, HAVAL-128, HAVAL-160, HAVAL-192, HAVAL-256, TIGER, TIGER-128, TIGER-160, GOST, WHIRLPOOL, SNEFRU-128, SNEFRU-256") (license gpl2+)))