aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorIgor Goryachev via Guix-patches via <guix-patches@gnu.org>2024-08-05 13:44:50 +0300
committerAndrew Tropin <andrew@trop.in>2024-08-05 17:15:01 +0400
commit4c2197414e4617a9f88f3c439407b457b48c2b83 (patch)
tree7853b82842117ea727b01fe8414de01b5d9297bf /gnu/packages
parentdf79cd27f65d4d19613ce938ea0fb6b85fd409ca (diff)
downloadguix-4c2197414e4617a9f88f3c439407b457b48c2b83.tar.gz
guix-4c2197414e4617a9f88f3c439407b457b48c2b83.zip
gnu: Add erlang-fast-tls.
* gnu/packages/erlang-xyz.scm (erlang-fast-tls): New variable. Change-Id: Ibda856e308b68f5e1dba4a7a541e0f2438aae737 Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/erlang-xyz.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 58b503b49c..2d0d8cd567 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -20,6 +20,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages erlang)
#:use-module (gnu packages python)
+ #:use-module (gnu packages tls)
#:use-module (guix build-system rebar)
#:use-module (guix download)
#:use-module (guix gexp)
@@ -268,6 +269,46 @@ implementation.")
(home-page "https://hex.pm/packages/ezlib")
(license license:asl2.0)))
+(define-public erlang-fast-tls
+ (package
+ (name "erlang-fast-tls")
+ (version "1.1.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "fast_tls" version))
+ (sha256
+ (base32 "0nsh5597pa1643kj2mmp05anss2r0gq83al0rm45w0ip768l458k"))))
+ (build-system rebar-build-system)
+ (inputs (list erlang-p1-utils openssl))
+ (native-inputs (list erlang-pc openssl))
+ (arguments
+ (list
+ #:tests? #f ; some required files are absent
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-/bin/sh
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((sh (search-input-file inputs "/bin/sh")))
+ (substitute* "configure"
+ (("/bin/sh") sh)))))
+ (add-after 'unpack 'set-environment
+ (lambda _
+ (setenv "HOME" "/tmp")
+ (setenv "CC" "gcc")
+ (let ((openssl (assoc-ref %build-inputs "openssl")))
+ (setenv "LDFLAGS" (string-append "-L" openssl "/lib"))
+ (setenv "CFLAGS" (string-append "-I" openssl "/include")))))
+ (add-before 'build 'configure
+ (lambda _
+ (invoke "./configure"))))))
+ (synopsis "TLS/SSL OpenSSL-based native driver for Erlang/Elixir")
+ (description
+ "This package provides TLS/SSL @code{OpenSSL}-based native driver
+for Erlang/Elixir.")
+ (home-page "https://hex.pm/packages/fast_tls")
+ (license license:asl2.0)))
+
(define-public erlang-unicode-util-compat
(package
(name "erlang-unicode-util-compat")