aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:15:07 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:07 +0000
commit495a65cd9aa4a4c9fa3ef6ce28d4beb213464cc0 (patch)
tree22ddcd1c019e9a87a62ad0fef680f883e677c0d0 /gnu/packages
parent0e7b61b54799cfea043f30d24c4509304582390b (diff)
downloadguix-495a65cd9aa4a4c9fa3ef6ce28d4beb213464cc0.tar.gz
guix-495a65cd9aa4a4c9fa3ef6ce28d4beb213464cc0.zip
gnu: Add python-poetry-plugin-export.
* gnu/packages/python-xyz.scm (python-poetry-plugin-export): New variable. Change-Id: Ic7dfe9bc84c634bb17492246a3fbe20d2dda9b4d
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0ce7244dbc..e46f4a7e0c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1873,6 +1873,30 @@ scatter plots, histograms and heatmaps in the terminal using braille dots.")
the versioning system in PEP 517 build frontends.")
(license license:expat)))
+(define-public python-poetry-plugin-export
+ (package
+ (name "python-poetry-plugin-export")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "poetry_plugin_export" version))
+ (sha256
+ (base32 "0qgw6w4xaw7cz9ykw376c5hcg9v2k30lnmna6pc9b4ymhn51d9hz"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f)) ;tests cycle with poetry
+ (native-inputs
+ (list python-poetry-core))
+ (propagated-inputs
+ (list python-pendulum))
+ (home-page "https://python-poetry.org/")
+ (synopsis "Poetry plugin to export the dependencies to various formats")
+ (description
+ "Poetry plugin to export the dependencies to various formats.")
+ (license license:expat)))
+
(define-public python-portpicker
(package
(name "python-portpicker")