aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-12-15 17:50:41 +0100
committerLudovic Courtès <ludo@gnu.org>2024-12-22 22:55:32 +0100
commit43c16ce7fa168ece8d7e750d37667f315022a717 (patch)
tree31bb34f764ea37bce4cca3ddbd8f64ec57457f74 /gnu/packages
parentf63c81d8af46ee7738ddb9678ef4db7a6b6e3287 (diff)
downloadguix-43c16ce7fa168ece8d7e750d37667f315022a717.tar.gz
guix-43c16ce7fa168ece8d7e750d37667f315022a717.zip
gnu: python-gitpython: Rewrite to use gexps.
* gnu/packages/version-control.scm (python-gitpython)[arguments]: Change to gexps; use ‘search-input-file’. Change-Id: I4fb2ce74262a05aaf32644dd3b8bfb674747fdbe
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/version-control.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 15e2e0a5ea..722c9602de 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;; Copyright © 2013-2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013-2022, 2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
@@ -1647,15 +1647,16 @@ allowing to handle large objects with a small memory footprint.")
"1rarp97cpjnhi106k2yhb7kygdyflmlgq0icxv3ggzl4wvszv0yz"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ;XXX: Tests can only be run within the GitPython repository.
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'embed-git-reference
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "git/cmd.py"
- (("git_exec_name = \"git\"")
- (string-append "git_exec_name = \""
- (assoc-ref inputs "git")
- "/bin/git\""))))))))
+ (list #:tests? #f ;XXX: tests can only be run within the GitPython repository
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'embed-git-reference
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "git/cmd.py"
+ (("git_exec_name = \"git\"")
+ (string-append "git_exec_name = \""
+ (search-input-file inputs "/bin/git")
+ "\""))))))))
(inputs
(list git))
(propagated-inputs