aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-07 20:43:11 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:16 -0400
commit42c99214114b4ebad205cfeb13d8dcdf293b8329 (patch)
treec541e89a5ef61a47046fa3ee12940df933b5e6bf /gnu/packages
parentaed6e3939bb824174754e319a343aa4b06ab727d (diff)
downloadguix-42c99214114b4ebad205cfeb13d8dcdf293b8329.tar.gz
guix-42c99214114b4ebad205cfeb13d8dcdf293b8329.zip
gnu: Add ruby-rake-manifest.
* gnu/packages/ruby.scm (ruby-rake-manifest): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f240c95ef0..85b6a737b6 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10413,6 +10413,40 @@ in standard Ruby syntax.")
(home-page "https://github.com/ruby/rake")
(license license:expat)))
+(define-public ruby-rake-manifest
+ (package
+ (name "ruby-rake-manifest")
+ (version "0.2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mvz/rake-manifest")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16k2yvg773c25kp2vhzhp01rhf53k0nhrcmpv34k1fridw90r2k8"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list
+ #:test-target "default"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'check) ;moved after the install phase
+ (add-after 'install 'check
+ (assoc-ref %standard-phases 'check))
+ (add-before 'check 'set-GEM_PATH
+ (lambda _
+ (setenv "GEM_PATH" (string-append
+ (getenv "GEM_PATH") ":"
+ #$output "/lib/ruby/vendor_ruby")))))))
+ (native-inputs (list ruby-rspec ruby-simplecov))
+ (synopsis "Rake tasks to generate and check a manifest file")
+ (description "This package provides Rake tasks to generate and check a
+manifest file.")
+ (home-page "https://github.com/mvz/rake-manifest")
+ (license license:expat)))
+
(define-public ruby-childprocess
(package
(name "ruby-childprocess")