aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDistopico <distopico@riseup.net>2023-07-23 13:41:32 -0500
committerAndreas Enge <andreas@enge.fr>2023-07-24 17:38:29 +0200
commit3adde30af52d4be347d610c0bdd543e0fdd6d64d (patch)
treea142a2f6c27181fc9d60eb74f78e97226bc4fd17 /gnu/packages
parentcf9904bcc8dd03e73675475bb4d8746dc434e415 (diff)
downloadguix-3adde30af52d4be347d610c0bdd543e0fdd6d64d.tar.gz
guix-3adde30af52d4be347d610c0bdd543e0fdd6d64d.zip
gnu: Add sdkmanager.
* gnu/packages/android.scm (sdkmanager): New variable. Co-authored-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/android.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index f35c2398bd..b9b8b89208 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020 Sergey Trofimov <sarg@sarg.org.ru>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system trivial)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
@@ -721,6 +723,35 @@ file system.")
"This package provides @command{fastboot}, a tool to upload file system images to Android devices.")
(license license:asl2.0)))
+(define-public sdkmanager
+ (package
+ (name "sdkmanager")
+ (version "0.6.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sdkmanager" version ".tar.gz"))
+ (sha256
+ (base32
+ "11as7n2mj3nbqsqb3ivyv9985n73i022s748qvjg36cs8ig50afx"))))
+ (build-system pyproject-build-system)
+ (inputs (list python-requests python-argcomplete python-urllib3 gnupg))
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-before 'build 'patch-gnupg
+ (lambda _
+ (substitute* "sdkmanager.py"
+ (("gpgv")
+ (string-append #$(this-package-input "gnupg")
+ "/bin/gpgv"))))))))
+ (home-page "https://gitlab.com/fdroid/sdkmanager")
+ (synopsis "Replacement for Android sdkmanager written in Python")
+ (description
+ "This package provides a drop-in replacement for sdkmanager from
+the Android SDK. It is written in Python and part of the F-Droid
+project. It implements the exact API of the Android sdkmanager command
+line. The project also attempts to maintain the same terminal output.")
+ (license license:agpl3+)))
+
(define-public android-udev-rules
(package
(name "android-udev-rules")