aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:08:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:08:59 +0200
commit3ad3fac7a28ea8f3bf76a493dd5352f45ec0327b (patch)
tree790b58b817c250b3defe59b45446b99050f26e44 /gnu/packages
parent2d1f5a3802d7bc8a4ad50adaaab784d2612a0cae (diff)
downloadguix-3ad3fac7a28ea8f3bf76a493dd5352f45ec0327b.tar.gz
guix-3ad3fac7a28ea8f3bf76a493dd5352f45ec0327b.zip
gnu: Add texlive-uptex.
* gnu/packages/tex.scm (texlive-uptex): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8f30a2697f..314410f2ba 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14038,6 +14038,47 @@ barcodes.")
and e-upTeX.")
(license license:bsd-3)))
+(define-public texlive-uptex
+ (package
+ (name "texlive-uptex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/euptex.1"
+ "doc/man/man1/euptex.man1.pdf"
+ "doc/man/man1/upbibtex.1"
+ "doc/man/man1/upbibtex.man1.pdf"
+ "doc/man/man1/uppltotf.1"
+ "doc/man/man1/uppltotf.man1.pdf"
+ "doc/man/man1/uptex.1"
+ "doc/man/man1/uptex.man1.pdf"
+ "doc/man/man1/uptftopl.1"
+ "doc/man/man1/uptftopl.man1.pdf")
+ (base32
+ "14hn2n6jbibbqbdr72j74z5bz003jnlabi3kja0f0waxhas680gd")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:create-formats #~(list "euptex" "uptex")))
+ (propagated-inputs
+ (list texlive-cm
+ texlive-etex
+ texlive-hyphen-base
+ texlive-knuth-lib
+ texlive-plain
+ texlive-ptex-base
+ texlive-uptex-base
+ texlive-uptex-fonts))
+ (home-page "https://ctan.org/pkg/uptex")
+ (synopsis "Unicode version of pTeX")
+ (description
+ "upTeX is an extension of pTeX, using UTF-8 input and producing UTF-8 output.
+It was originally designed to improve support for Japanese, but is also useful
+for documents in Chinese and Korean. It can process Chinese simplified,
+Chinese traditional, Japanese, and Korean simultaneously, and can also process
+original LaTeX with @code{\\inputenc@{utf8@}} and Babel
+(Latin/Cyrillic/Greek etc.) by switching its @code{\\kcatcode} tables.")
+ (license license:bsd-3)))
+
(define-public texlive-uptex-fonts
(package
(name "texlive-uptex-fonts")