aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 18:25:06 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 19:53:16 +0200
commit3a396b00675fae70541eb4a9d2e0909654b1d3bf (patch)
tree567670f4dbc80083ca274b98c4ceb980da1774a7 /gnu/packages
parentd4ffa9630277fa8699c783c08381d688626d4bc3 (diff)
downloadguix-3a396b00675fae70541eb4a9d2e0909654b1d3bf.tar.gz
guix-3a396b00675fae70541eb4a9d2e0909654b1d3bf.zip
gnu: python-genshi: Update to 0.7.5.
* gnu/packages/python-web.scm (python-genshi): Update to 0.7.5. [propagated-inputs]: Add PYTHON-SIX.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b7411d21fa..e789f9d837 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3926,7 +3926,7 @@ for Flask programs that are using @code{python-alembic}.")
(define-public python-genshi
(package
(name "python-genshi")
- (version "0.7.3")
+ (version "0.7.5")
(source
(origin
(method git-fetch)
@@ -3935,7 +3935,9 @@ for Flask programs that are using @code{python-alembic}.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "04bw7nd4wyn8ixnhik57hny2xpjjpn80k5hp6691inix5gc6rxaf"))))
+ (base32 "04i0caywiwrgw09grz988n15qr9lr31d9n6a529p8v80cy1fv23c"))))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
(build-system python-build-system)
(home-page "https://genshi.edgewall.org/")
(synopsis "Toolkit for generation of output for the web")
; ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>. (define-module (gnu packages security-token) #:use-module (gnu packages) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages curl) #:use-module (gnu packages libusb) #:use-module (gnu packages linux) #:use-module (gnu packages man) #:use-module (gnu packages perl) #:use-module (gnu packages pkg-config)) (define-public ccid (package (name "ccid") (version "1.4.27") (source (origin (method url-fetch) (uri (string-append "https://alioth.debian.org/frs/download.php/file/4218/" "ccid-" version ".tar.bz2")) (sha256 (base32 "0dyikpmhsph36ndgd61bs4yx437v5y0bmm8ahjacp1k9c1ly4q56")))) (build-system gnu-build-system) (arguments `(#:configure-flags (list (string-append "--enable-usbdropdir=" %output "/pcsc/drivers")) #:phases (modify-phases %standard-phases (add-after 'unpack 'patch-Makefile (lambda _ (substitute* "src/Makefile.in" (("/bin/echo") (which "echo"))) #t))))) (native-inputs `(("perl" ,perl) ("pkg-config" ,pkg-config))) (inputs `(("libusb" ,libusb) ("pcsc-lite" ,pcsc-lite))) (home-page "https://pcsclite.alioth.debian.org/ccid.html") (synopsis "PC/SC driver for USB smart card devices") (description "This package provides a PC/SC IFD handler implementation for devices compliant with the CCID and ICCD protocols. It supports a wide range of readers and is needed to communicate with such devices through the @command{pcscd} resource manager.") (license license:lgpl2.1+))) (define-public libyubikey (package (name "libyubikey") (version "1.13") (source (origin (method url-fetch) (uri (string-append "https://developers.yubico.com/yubico-c/Releases/" name "-" version ".tar.gz")) (sha256 (base32 "009l3k2zyn06dbrlja2d4p2vfnzjhlcqxi88v02mlrnb17mx1v84")))) (build-system gnu-build-system) (synopsis "Development kit for the YubiKey authentication device") (description "This package contains a C library and command-line tools that make up the low-level development kit for the Yubico YubiKey authentication device.") (home-page "https://developers.yubico.com/yubico-c/") (license license:bsd-2))) (define-public pcsc-lite (package (name "pcsc-lite") (version "1.8.22") (source (origin (method url-fetch) (uri (string-append "https://alioth.debian.org/frs/download.php/file/4225/" "pcsc-lite-" version ".tar.bz2")) (sha256 (base32 "01flkdyqs7kr6c63dv2qg8dwir3v9jlr9rzlw7vafrivxmhqydba")))) (build-system gnu-build-system) (arguments `(#:configure-flags '("--enable-usbdropdir=/var/lib/pcsc/drivers"))) (native-inputs `(("perl" ,perl) ; for pod2man ("pkg-config" ,pkg-config))) (inputs `(("libudev" ,eudev))) (home-page "https://pcsclite.alioth.debian.org/pcsclite.html") (synopsis "Middleware to access a smart card using PC/SC") (description "pcsc-lite provides an interface to communicate with smartcards and readers using the SCard API. pcsc-lite is used to connect to the PC/SC daemon from a client application and provide access to the desired reader.") (license (list license:bsd-3 ; pcsc-lite license:expat ; src/sd-daemon.[ch] license:isc ; src/strlcat.c src/strlcpy.c license:gpl3+)))) ; src/spy/* (define-public ykclient (package (name "ykclient") (version "2.15") (source (origin (method url-fetch) (uri (string-append "https://developers.yubico.com/yubico-c-client/Releases/" name "-" version ".tar.gz")) (sha256 (base32 "05jhx9waj3pl120ddnwap1v3bjrnbfhvf3lxs2xmhpcmwzpwsqgl")))) (build-system gnu-build-system) ;; There's just one test, and it requires network access to access ;; yubico.com, so skip it. (arguments '(#:tests? #f)) (native-inputs `(("pkg-config" ,pkg-config) ("help2man" ,help2man))) (inputs `(("curl" ,curl))) (synopsis "C library to validate one-time-password YubiKeys") (description "YubiKey C Client Library (libykclient) is a C library used to validate a one-time-password (OTP) YubiKey against Yubico’s servers. See the Yubico website for more information about Yubico and the YubiKey.") (home-page "https://developers.yubico.com/yubico-c-client/") (license license:bsd-2)))